Last Comment Bug 737941 - Sent emails containing a Filelink appear as containing a (fake) attachment
: Sent emails containing a Filelink appear as containing a (fake) attachment
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Message Reader UI (show other bugs)
: 13 Branch
: All All
: -- major (vote)
: Thunderbird 14.0
Assigned To: David :Bienvenu
:
Mentors:
Depends on:
Blocks: BigFiles
  Show dependency treegraph
 
Reported: 2012-03-21 11:05 PDT by Jb Piacentino
Modified: 2012-04-02 16:10 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Filelink interpreted as attachment (73.81 KB, image/png)
2012-03-21 11:05 PDT, Jb Piacentino
no flags Details
proposed fix (2.69 KB, patch)
2012-03-29 20:21 PDT, David :Bienvenu
mconley: review+
standard8: approval‑comm‑aurora+
Details | Diff | Review

Description Jb Piacentino 2012-03-21 11:05:18 PDT
Created attachment 608025 [details]
Filelink interpreted as attachment

STR

- Create a Filelink
- Send
- Locate it in the Sent folder
- It's presented as if it contained a regular attachment (21 byte long). 

Expected behaviour:
- Do not mark it as containing an attachment.
Comment 1 David :Bienvenu 2012-03-21 11:49:58 PDT
they do have an attachment, the html part that describes the file link.
Comment 2 Jb Piacentino 2012-03-22 01:33:39 PDT
Ok, fair enough. 

But the attachment is not interpreted as an html part, but rather as the original file type. In the attached screenshot for example, it looks like a jpg file, of 21 bytes size, and TB tries to render it... and fails. That does not seem right, does it ?
Comment 3 Magnus Melin 2012-03-22 06:57:13 PDT
Isn't it just that it renders the html part, but the remote image isn't allowed to be shown?
Comment 4 David :Bienvenu 2012-03-22 07:42:23 PDT
(In reply to Magnus Melin from comment #3)
> Isn't it just that it renders the html part, but the remote image isn't
> allowed to be shown?

we can't render the remote image - we just have a link to a web page which has a download link somewhere on it...
Comment 5 Jim Porter (:squib) 2012-03-22 13:26:21 PDT
If I had to guess, it's trying to render the html part as a jpg.
Comment 6 David :Bienvenu 2012-03-22 13:40:54 PDT
things are all still a bit of blur after the exciting big files landing. My intent was that the attachments have text/html content-type, but it looks like they have the attachment type of the actual attachment. They've also got Content-Disposition: attachment;
 filename="713645.txt". I think if I took out the filename part on save/send, then we wouldn't show the attachment in the attachment area, and I need to fix the content type as well. And then I have to make sure that loading a draft msg with a big file attachment gets the filename from the X-Mozilla-Cloud-Part header...
Comment 7 David :Bienvenu 2012-03-29 20:21:35 PDT
Created attachment 610801 [details] [diff] [review]
proposed fix

this makes the cloud part be text/html, and puts in a link, and removes the filename so we won't display it as an attachment in the UI.
Comment 8 Mike Conley (:mconley) - (needinfo me!) 2012-04-02 06:35:06 PDT
Comment on attachment 610801 [details] [diff] [review]
proposed fix

Review of attachment 610801 [details] [diff] [review]:
-----------------------------------------------------------------

This makes sense to me.  Good stuff!
Comment 9 David :Bienvenu 2012-04-02 10:30:51 PDT
Comment on attachment 610801 [details] [diff] [review]
proposed fix

[Approval Request Comment]

User impact if declined: 
cloud file attachments show up as real attachments in attachment pane.
Comment 10 Mike Conley (:mconley) - (needinfo me!) 2012-04-02 14:11:47 PDT
Committed to comm-aurora as http://hg.mozilla.org/releases/comm-aurora/rev/99876e31f37e
Comment 11 Mike Conley (:mconley) - (needinfo me!) 2012-04-02 16:08:47 PDT
Committed to comm-central as http://hg.mozilla.org/comm-central/rev/477abb7f3627

Note You need to log in before you can comment on or make changes to this bug.