Closed Bug 738032 Opened 8 years ago Closed 8 years ago

DevMgrADB shouldn't copy entire directory when checking if we can use run-as

Categories

(Testing :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla14

People

(Reporter: wlach, Assigned: wlach)

Details

Attachments

(1 file)

No description provided.
(sorry for the weird bug, trying to get used to git-bz)

I think the reason for this should be self evident. If you initialize devicemanageradb in a directory with many/big files, it'll try to copy them all onto the device, which is ridiculous behaviour.
Assignee: nobody → wlachance
Comment on attachment 608086 [details] [diff] [review]
DevMgrADB shouldn't copy entire directory when checking if we can use run-as

(sorry for the weird bug, trying to get used to git-bz)

I think the reason for this should be self evident. If you initialize devicemanageradb in a directory with many/big files, it'll try to copy them all onto the device, which is ridiculous behaviour.
Attachment #608086 - Flags: review?(gbrown)
Comment on attachment 608086 [details] [diff] [review]
DevMgrADB shouldn't copy entire directory when checking if we can use run-as

Review of attachment 608086 [details] [diff] [review]:
-----------------------------------------------------------------

As discussed, I expect os.path.abspath(sys.argv[0]) to resolve to a filename in the normal case, but your approach should save us from grief / extra copying in some special cases where argv is not set.
Attachment #608086 - Flags: review?(gbrown) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/d6418c8e8fbf
Flags: in-testsuite-
Keywords: checkin-needed
Target Milestone: --- → mozilla14
https://hg.mozilla.org/mozilla-central/rev/d6418c8e8fbf
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.