style a:hover doesn't work

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: john russell, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
my stylesheet zestyle.css  sets a:hover to parallel what active 
does -- red , no underline   
but it doesn't work in mozilla !!

Comment 1

17 years ago
Mozilla is following the correct specificity rules.

a:link and a:visited are defined AFTER a:hover, therefore they override it and
the hover state is never displayed.

Invalid bug.

Comment 2

17 years ago
marking INVALID. Please change the order of your a: rules, so they match the
standards specification, thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
verified.  and looks like the rule order has been changed.

The problem is that a:link and a:visited have the same exact specificity as
a:hover (all have one element and one class).  So the latest one of the rules
mentioned that is applicable is applied.  Thus a:hover should come after a:link
or be written as a:link:hover to make it more specific.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.