Closed Bug 738203 Opened 9 years ago Closed 9 years ago

"You're running an unknown version of Firefox"

Categories

(www.mozilla.org :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: derek, Assigned: jlong)

References

()

Details

Attachments

(7 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120314195616

Steps to reproduce:

I opened the lid of my sleeping MacBook Pro laptop, with Firefox 12 still active.


Actual results:

I saw this message out of the blue, the first time I ever had it, and since the latest 12 beta got auto-installed.


Expected results:

Firefox should not flag a beta version as "unknown". It never has before to my knowledge or recollection.
Attached image "get latest version"
tells me I am up to date while at the same time offering a link to download the latest version
even though v.12 is running, I am offered v.11
Confirming, I have this as well today on two different machines. Moving to websites.
Status: UNCONFIRMED → NEW
Component: Untriaged → www.mozilla.org
Ever confirmed: true
Product: Firefox → Websites
QA Contact: untriaged → www-mozilla-org
Version: 12 Branch → unspecified
I am seeing this running Firefox 12 B2.
Component: www.mozilla.org → www.mozilla.org/firefox
QA Contact: www-mozilla-org → www-mozilla-com
Can you list specific steps to reproduce, including URLs?

I'll make sure this gets covered manually after being fixed, and then we can do automation.  Thanks!
Flags: in-testsuite?
Let me try to get some STR. One thing I wanted to mention is that I might have been using different profiles when testing (using an aurora profile launch beta, for example)
STR:

1. Download Firefox 12B3 from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/12.0b3-candidates/build1/mac/en-US/
2. Launch the build with an existing Nightly Profile
3. Receive the unknown version page

If I launch with a new profile I get the correct page.
I had a Firefox 11 (Release) profile and download Firefox 12 (Beta) and saw the what's new page on first run of 12.
OS: Mac OS X → All
Hardware: x86 → All
Cheng reported in the Channel Meeting that there is trending going on indicating users are hitting this: see https://wiki.mozilla.org/Firefox/Channels/Meetings/2012-04-10#Roundtable
I suspect this is a problem in the .htaccess file. This is part of the reason I filed bug 736934 to make updating the applicable sites less of a minefield.

James - would you mind taking a look? STR for your purposes would be

1) Download and install the build at https://www.mozilla.org/en-US/firefox/beta/
2) Go to http://www.mozilla.org/en-US/firefox/12.0/whatsnew/

Expected result: the page should not show "You're running an unknown version of Firefox"
Assignee: nobody → jlong
(In reply to Alex Keybl [:akeybl] from comment #10)
> I suspect this is a problem in the .htaccess file. This is part of the
> reason I filed bug 736934 to make updating the applicable sites less of a
> minefield.
> 
> James - would you mind taking a look? STR for your purposes would be
> 
> 1) Download and install the build at
> https://www.mozilla.org/en-US/firefox/beta/
> 2) Go to http://www.mozilla.org/en-US/firefox/12.0/whatsnew/
> 
> Expected result: the page should not show "You're running an unknown version
> of Firefox"

This is not an .htaccess issue, it's an issue that runs deeper to the sloppiness of the PHP site.

Two things at play:

* There's a function `isValidVersionByReleaseNotes` called by the page to see if the version is valid. This works by checking of the  file /firefox/<version>/releasenotes exists. Yuck. It didn't exists because the version string was 11.0 and the filesystem folder is 11.0beta.

* There's a check to see if the versions are *equal* in that whatsnew PHP code. I changed it to check is it is less than.

Fixes are committed in r104174

If you test this on the www-dev site, and verify, I can push that out.
Whiteboard: r=104174 b=trunk
(In reply to James Long (:jlongster) from comment #11)
> (In reply to Alex Keybl [:akeybl] from comment #10)
> > I suspect this is a problem in the .htaccess file. This is part of the
> > reason I filed bug 736934 to make updating the applicable sites less of a
> > minefield.
> > 
> > James - would you mind taking a look? STR for your purposes would be
> > 
> > 1) Download and install the build at
> > https://www.mozilla.org/en-US/firefox/beta/
> > 2) Go to http://www.mozilla.org/en-US/firefox/12.0/whatsnew/
> > 
> > Expected result: the page should not show "You're running an unknown version
> > of Firefox"
> 
> This is not an .htaccess issue, it's an issue that runs deeper to the
> sloppiness of the PHP site.
> 
> Two things at play:
> 
> * There's a function `isValidVersionByReleaseNotes` called by the page to
> see if the version is valid. This works by checking of the  file
> /firefox/<version>/releasenotes exists. Yuck. It didn't exists because the
> version string was 11.0 and the filesystem folder is 11.0beta.
> 
> * There's a check to see if the versions are *equal* in that whatsnew PHP
> code. I changed it to check is it is less than.
> 
> Fixes are committed in r104174
> 
> If you test this on the www-dev site, and verify, I can push that out.

Works fine on Firefox 11 and Nightly http://www-dev.allizom.org/en-US/firefox/12.0/whatsnew/ but visiting in Chrome and Safari now says you have an updated version of Firefox instead of You’re running an unknown version of Firefox.
Keywords: qawanted
Unassigning bugs from James that are not migration-related bedrock platform bugs. Let me know if you have any questions.
Assignee: jlong → nobody
Component: www.mozilla.org/firefox → www.mozilla.org
Derek, that's actually out of scope for this bug. The "download latest version" link in the about panel simply is hardcoded to /firefox/fx, which will always point to the latest release version, not any beta or other version.

If you want that workflow to work, the link in the about panel needs to be a lot smarter.
(In reply to James Long (:jlongster) from comment #11)
> Fixes are committed in r104174
> 
> If you test this on the www-dev site, and verify, I can push that out.

Didn't realize this was on hold. I've verified that I now get "Hooray! Your Firefox is up to date." on [1]. Let's push out the fix today in preparation for tomorrow's release.

[1] https://www-dev.allizom.org/en-US/firefox/12.0/whatsnew/
Target Milestone: --- → 2.2
Sounds good. Raymond, from what I see in the code, that's always happened and I guess it's ok because it's the whatsnew page and should never be hit by other browsers.

Taking this bug back since it's already done.
Assignee: nobody → jlong
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: r=104174 b=trunk → r=104172 b=trunk
pushed to production r104681
Whiteboard: r=104172 b=trunk
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
Restoring unintended removal of in-testsuite flag.
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.