Last Comment Bug 738302 - disable building docs for libunwind so b2g starts building again (follow on to bug 683229)
: disable building docs for libunwind so b2g starts building again (follow on t...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Gecko Profiler (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla14
Assigned To: :Ehsan Akhgari
:
:
Mentors:
Depends on: 745165
Blocks: 719491
  Show dependency treegraph
 
Reported: 2012-03-22 09:41 PDT by John Ford [:jhford] CET/CEST Berlin Time
Modified: 2012-04-13 05:46 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (1.11 KB, patch)
2012-03-22 14:16 PDT, :Ehsan Akhgari
b56girard: review+
Details | Diff | Splinter Review

Description John Ford [:jhford] CET/CEST Berlin Time 2012-03-22 09:41:09 PDT
libunwind is trying to build its documentation.  Unless we need this documentation, we should disable building the documentation because building it wastes time and introduces new build time dependencies that aren't otherwise useful or desirable.

This means that our B2G builds that are about to go live in production aren't building anymore.

make[7]: Leaving directory `/builds/slave/m-cen-b2g/build/obj-b2g/tools/profiler/libunwind/src/tests'
Making all in doc
make[7]: Entering directory `/builds/slave/m-cen-b2g/build/obj-b2g/tools/profiler/libunwind/src/doc'
latex2man -t /builds/slave/m-cen-b2g/build/tools/profiler/libunwind/src/doc/libunwind.trans /builds/slave/m-cen-b2g/build/tools/profiler/libunwind/src/doc/unw_get_proc_info_by_ip.tex unw_get_proc_info_by_ip.man
make[7]: latex2man: Command not found
make[7]: *** [unw_get_proc_info_by_ip.man] Error 127
make[7]: Leaving directory `/builds/slave/m-cen-b2g/build/obj-b2g/tools/profiler/libunwind/src/doc'
make[6]: *** [all-recursive] Error 1
Comment 1 Benoit Girard (:BenWa) 2012-03-22 09:44:43 PDT
this means that b2g is building with profiling enabled. Is that expected?
Comment 2 John Ford [:jhford] CET/CEST Berlin Time 2012-03-22 09:48:04 PDT
(In reply to Benoit Girard (:BenWa) from comment #1)
> this means that b2g is building with profiling enabled. Is that expected?

According to the mozconfig given to me by the b2g team, yes

http://hg.mozilla.org/mozilla-central/file/default/b2g/config/mozconfigs/linux32/debug
Comment 3 :Ehsan Akhgari 2012-03-22 09:53:44 PDT
libunwind itself does not support building without documentation, but we may be able to trick it somehow...
Comment 4 :Ehsan Akhgari 2012-03-22 14:16:50 PDT
Created attachment 608471 [details] [diff] [review]
Patch (v1)

This is a hack, but I think not a very bad one, in that we don't need to modify libunwind at all.  The way that this patch works is that it replaces the commands in the docs Makefile (the one in the objdir) with echo so that they won't do anything useful.
Comment 6 Marco Bonardo [::mak] 2012-03-23 05:50:26 PDT
https://hg.mozilla.org/mozilla-central/rev/51a252a832b9

Note You need to log in before you can comment on or make changes to this bug.