Last Comment Bug 738367 - Avoid undefined properties JS warnings caused by imIncomingServer.js
: Avoid undefined properties JS warnings caused by imIncomingServer.js
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: Thunderbird 14.0
Assigned To: Florian Quèze [:florian] [:flo]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 11:30 PDT by Florian Quèze [:florian] [:flo]
Modified: 2012-04-02 04:06 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Patch (1.64 KB, patch)
2012-03-22 11:30 PDT, Florian Quèze [:florian] [:flo]
mozilla: review+
mozilla: approval‑comm‑aurora+
Details | Diff | Review

Description Florian Quèze [:florian] [:flo] 2012-03-22 11:30:58 PDT
Created attachment 608403 [details] [diff] [review]
Patch

The attached patch cleans up various warnings caused by imIncomingServer.js not implementing some properties that end up actually read.

Example of warning this fixes:
Warning: reference to undefined property mgr.accounts
Source File: chrome://messenger/content/mail3PaneWindowCommands.js
Line: 412

The warnings displayed in the console were all incorrect because of bug 383524 so this wasn't as easy to figure out as it could have been...
Comment 1 David :Bienvenu 2012-03-22 15:34:30 PDT
Comment on attachment 608403 [details] [diff] [review]
Patch

however, since you're cleaning up errors, I see several of these different errors on every startup,:

Timestamp: 3/22/2012 3:32:27 PM
Error: Attempting to set a null username to an imIncomingServer
Source File: file:///C:/builds/tbirdhq/objdir-tb/mozilla/dist/bin/components/imIncomingServer.js
Line: 183

Timestamp: 3/22/2012 3:32:41 PM
Error: account is null
Source File: file:///C:/builds/tbirdhq/objdir-tb/mozilla/dist/bin/components/imContacts.js
Line: 1254
Comment 2 Florian Quèze [:florian] [:flo] 2012-03-22 15:57:06 PDT
(In reply to David :Bienvenu from comment #1)

> Timestamp: 3/22/2012 3:32:27 PM
> Error: Attempting to set a null username to an imIncomingServer
> Source File:
> file:///C:/builds/tbirdhq/objdir-tb/mozilla/dist/bin/components/
> imIncomingServer.js
> Line: 183

You see it once per chat account. This is caused by bug 736434, you have already r+'ed the fix, but I haven't done the checkin yet.

> Timestamp: 3/22/2012 3:32:41 PM
> Error: account is null
> Source File:
> file:///C:/builds/tbirdhq/objdir-tb/mozilla/dist/bin/components/imContacts.js
> Line: 1254

I think this is because to work-around bug 736035 you hand removed the preferences of your chat accounts but haven't removed the blist.sqlite file from your profile at the same time. I think you see this error once per contact you had before hand removing your chat accounts.
Comment 3 Florian Quèze [:florian] [:flo] 2012-03-23 04:03:50 PDT
http://hg.mozilla.org/comm-central/rev/60f3a527c8b0
Comment 4 Florian Quèze [:florian] [:flo] 2012-03-30 06:08:06 PDT
Comment on attachment 608403 [details] [diff] [review]
Patch

[Approval Request Comment]
This isn't strictly required for aurora as it's only cleaning up some error console noise, but I think not cluttering the error console with pointless messages helps gathering actionable feedback, so I would like us to take this fix on aurora.
Comment 5 Florian Quèze [:florian] [:flo] 2012-04-02 04:06:38 PDT
http://hg.mozilla.org/releases/comm-aurora/rev/ff0b90dbcd98

Note You need to log in before you can comment on or make changes to this bug.