In a folder, Select all (ctrl-a) and execute command -> crash

VERIFIED FIXED in mozilla0.9

Status

SeaMonkey
MailNews: Message Display
P1
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: selmer (gone), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash})

Trunk
mozilla0.9
x86
All
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
3/28 04 WinNT

In a newsgroup, use the expand all menu to make every message visible and then
use ctrl-a to select everything.  Using command keys either doesn't work or
crashes.  Selecting one of the messages after doing this also seems to crash.

Talkback reports were submitted, but the talkback UI doesn't tell me what the
IDs were.  Should be simple to repro though.
(Reporter)

Updated

18 years ago
Keywords: crash
QA Contact: esther → stephend
I can't reproduce this crash with the same build (2001032804) on Windows 2000 by
doing a View | Messages | Expand All Threads and then doing a CTRL-A.  How many
times did you crash, Steve?  
(Reporter)

Comment 2

18 years ago
After you select all, you have to try to do something to the selected messages.
 You can also try just selecting a single message at this point.  Both of these
have crashed on me consistently.  Try using the menu to do mark as read on the
full selection.
Still doesn't crash on my system.
Talkback also didn't list any crashes from you with the date of 3/28.
(Reporter)

Comment 5

18 years ago
I guess my machine has reverted to being evil again.  Maybe talkback didn't
actually report the incidents and that's why I didn't get ID numbers.  It shows
them as in the sent status though.  Maybe that's a different bug...

It's tough for me to imagine why this crash would be specific to my machine or
related to my profile or something.  Any theories?
No, but I'll certainly test this again tomorrow on my machine with a new build.
 I can't see how it could be a corrupted profile issue, either, since I don't
think selecting messages touches .msf files, but I could be wrong.  Let's hope
we can figure something out tomorrow.

Comment 7

18 years ago
I get the same crash.  I can make it happen in a news folder as well as a mail
folder so changing the subject.

This happens to me on 2001032804 on Win 2000.

I couldn't make it happen selecting a message, but the following steps made it
crash consistently:

1.  open a folder
2.  Do Ctrl+A for select all
3.  Use main menu toolbar and go to Message | Mark | As Read
4.  Crash

I can't get on talkback now to get a stack, but here's the ID: TB28403978G
Keywords: nsbeta1
Priority: -- → P1
Summary: newsgroup: Select all (ctrl-a) and execute command -> crash → In a folder, Select all (ctrl-a) and execute command -> crash
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9
I definitely saw this today with build 2001032904 on Win2K.
coolness, this fix should fix a bunch of problems.

we forget an addref in one case (nsMsgDBView::GetDBForViewIndex), and had an
extra addref in another case (nsMsgSearchDBView::GetDBForViewIndex).

GetDBForIndex() is called when we mark read / unread, flag / unflag or delete
messages.  this could fix a bunch of problem.

it's been reviewed bienvenu, I'll land today.
Status: NEW → ASSIGNED
OS: Windows NT → All
*** Bug 74182 has been marked as a duplicate of this bug. ***

Comment 12

18 years ago
*** Bug 74127 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
*** Bug 72478 has been marked as a duplicate of this bug. ***
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Verified fixed in:
2001-04-02-08 on Mac OS 9.1
2001-04-02-04 on Windows 2000
2001-04-02-08 on Linux (Mandrake 7.2 with KDE)

Still takes a long time to mark all read, but that's a diff bugs.  
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.