HTML5 video shows "buffering UI" (darkened w/ throbber) while the video plays just fine underneath

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Trunk
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox13 unaffected, firefox14- unaffected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
STR:
 1. Load http://www.0xdeadbeef.com/~blizzard/weblog-videos/2010-sunrise-over-sweden/sunrise-over-sweden.ogv
 2. After the video has buffered a bit, click the scrubber to jump ahead into an already-buffered area.

ACTUAL RESULTS: the video plays, but the "buffering UI" shows up and stays on, obscuring the video.  Meanwhile, the scrubber is fully lit, showing that the whole video has been downloaded.
(Reporter)

Comment 1

7 years ago
Works:  Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Buggy:  Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20120321 Firefox/14.0a1
Keywords: regression
(Reporter)

Comment 2

7 years ago
Created attachment 608425 [details]
screencast of bug
Works: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Keywords: regressionwindow-wanted
(Reporter)

Comment 4

7 years ago
Yup, Beta is WFM: Mozilla/5.0 (X11; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0
Aurora is broken: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120322 Firefox/13.0a2
status-firefox13: --- → affected
status-firefox14: --- → affected
tracking-firefox13: --- → ?
tracking-firefox14: --- → ?
(Reporter)

Comment 5

7 years ago
Last good nightly: 2012-03-13
First bad nightly: 2012-03-14

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2012-03-13&enddate=2012-03-14
Keywords: regressionwindow-wanted
(Reporter)

Comment 6

7 years ago
m-i regression window:
Last good nightly: 2012-03-13
First bad nightly: 2012-03-14

Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d4496bf4bb64&tochange=0362bad5569c
I suspect this change: http://hg.mozilla.org/mozilla-central/rev/c7e4db80d280

Charles Chan - Bug 729111: Renable HTML5 centered play video button after video is resized.
Blocks: 729111
OS: Linux → All
Hardware: x86_64 → All
(Reporter)

Updated

7 years ago
Component: Video/Audio → Video/Audio Controls
Product: Core → Toolkit
QA Contact: video.audio → video.audio
No longer blocks: 729111
Depends on: 729111
Comment hidden (typo)
Comment hidden (typo)
Duplicate of this bug: 737767
(In reply to Jared Wein [:jaws] from comment #7)
> I suspect this change: http://hg.mozilla.org/mozilla-central/rev/c7e4db80d280
> 
> Charles Chan - Bug 729111: Renable HTML5 centered play video button after
> video is resized.

Stefan has confirmed this in bug 737767 comment 9.
Duplicate of this bug: 738666

Updated

7 years ago
tracking-firefox13: ? → +
tracking-firefox14: ? → +
The patch that caused this regression was backed out of Firefox 13 so we won't need to track it for that release anymore.
status-firefox13: affected → unaffected
tracking-firefox13: + → ---
Duplicate of this bug: 736588
Just to note, bug 736588 doesn't require seeking or touching the scrubber.
Summary: HTML5 video shows "buffering UI" (darkened w/ throbber) after I seek, while the video plays just fine underneath → HTML5 video shows "buffering UI" (darkened w/ throbber) while the video plays just fine underneath
(In reply to Jared Wein [:jaws] from comment #13)
> The patch that caused this regression was backed out of Firefox 13 so we
> won't need to track it for that release anymore.

It was backed out of FF14 and up as well (see bug 729111).
status-firefox14: affected → unaffected
tracking-firefox14: + → -
The link you provided is no longer available, can you please provide another one so I can test this on my end?
Also, is this still reproducible on your end ? If yes, can you please retest this using latest FF release and latest Nightly build (https://nightly.mozilla.org/) and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E).

Thanks.
Flags: needinfo?(dholbert)
(Reporter)

Comment 18

2 years ago
I don't know of another URL that reproduced this (probably any HTML5 video would work, though I'm not sure).  I can't reproduce it in current Nightly with an arbitrary HTML5 video that I just tested now, so I'm willing to bet this was fixed at some point in the last 4 years.

Resolving as WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(dholbert)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.