Unified Back Forward button styling broken when not attached to Location Bar

RESOLVED INVALID

Status

()

Firefox
Theme
RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: Optimizer, Unassigned)

Tracking

Trunk
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Due to bug 735691, then unified forward back buttons appears to be separated left right arrow (mirror images).
There were no specification of this behavior in the Australis design specs.
Only when the back forward buttons are placed right before the location bar, then the style becomes similar to what we already had in Nightly 13.
(Reporter)

Updated

6 years ago
Blocks: 735691
(Reporter)

Comment 1

6 years ago
I think this is mainly because the border got removed for all buttons except for the unified forward back button when attached to location bar. Still, the size difference and/or the circle around the back button should be maintained.
The Preview of that Pair of Buttons is different when invoking the Customization Palette too (compared to before bug 735691).
Duplicate of this bug: 767527

Comment 4

6 years ago
The OS I saw this on was Windows XP Home, so it's probably at least All Windows.

Also, so other people can find it, I'm mentioning what that was called back when Firefox 4 debuted: The keyhole is broken.

Comment 5

6 years ago
Forgot to mention something: Even when attached to the Location bar, the Back Forward Button doesn't style in small icon mode. However, if you turn large icon mode back on, the icons don't get bigger and it looks like small icon mode previously did.
(In reply to Girish Sharma [:Optimizer] from comment #1)
> I think this is mainly because the border got removed for all buttons except
> for the unified forward back button when attached to location bar. Still,
> the size difference and/or the circle around the back button should be
> maintained.

This was done on purpose, see bug 856665 comment 24.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.