Bookmarks broken in Firefox 11.0 mid-day 03/22/2012

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
7 years ago
6 years ago

People

(Reporter: ralphcyn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

I generally keep Firefox active all day.  Mid-day yesterday, a forced (?) restart of Firefox was invoked under the covers.


Actual results:

After the restart, I have no bookmarks, and the bookmark processor appears to be broken, i.e., I cannot add bookmarks.  I have tried copying a backup of my places.sqlite into my profile, but nothing changes.  I have tried uninstalling and reinstalling 11.0 and the beta 12, but get the same results.  If I uninstall, specifying not to save my profile data, the Bookmark pages look okay, and I can add bookmarks, but I've lost hundreds of my bookmarks.


Expected results:

I should have all of my old bookmarks.
(Reporter)

Comment 1

7 years ago
I tried to attach a copy of my places.sqlite, but it is too large (10KB).
Component: General → Places
Product: Mozilla Services → Toolkit
QA Contact: general → places
(Reporter)

Comment 2

7 years ago
Please let me know if there is documentation that I can provide for this problem.  My guess is there is something in one of the places files that is causing a problem.  When I try to use my current Bookmarks files, Bookmark processing fails, i.e., a larger than normal window opens for Bookmarks, but it is unpopulated.  Adding bookmarks fails.  If I let Firefox create new Bookmark files, I am able to save and manage Bookmarks as designed.
I guess it's too late now...
this was more a support ticket than a bug though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.