Closed Bug 738648 Opened 9 years ago Closed 9 years ago

Add images antialiasing support to PDF Viewer

Categories

(Firefox :: PDF Viewer, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: konst1089, Unassigned)

References

Details

(Whiteboard: [pdfjs-c-feature])

Attachments

(1 file)

57.90 KB, application/pdf
Details
Attached file Example pdf
Some pdf files (e.g. sheet music, scanned books) look bad without this feature in comparison with standalone pdf viewers (Adobe Acrobat on Windows, Evince on Linux etc.).
Screenshots:
Evince - http://uppix.net/a/1/8/d6d2506543b7ef7eb07419a55e6ac.png
Firefox - http://uppix.net/8/8/d/f055b282d23b3a23fa23d4a76cf89.png
Simple example is attached. Please, add this feature to pdf.js, it would significantly improve readability of such files.
Maybe you could try with and without hardware acceleration in Firefox to see if it changes something
I have tried this (both azure and layers acceleration). No changes.
Indeed, the way that PDF Viewer currently displays those PDFs could be improved.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [pdfjs-c-feature]
Duplicate of this bug: 741273
Type3 fonts anti-aliasing was implemented in https://github.com/mozilla/pdf.js/pull/1763 and part of the Nightly. See FF16 bug 778398:

> #1763 Type3 smoothing: pre-scale image in the paintImageMaskXObject

More on the subject and its performance, see bug 759172
Status: NEW → RESOLVED
Closed: 9 years ago
Depends on: 778398
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.