Closed Bug 738650 Opened 9 years ago Closed 9 years ago

Crash Reporter always crashes when bug 738633 occurs on Samsung Captivate

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 732629

People

(Reporter: xti, Unassigned)

Details

Firefox 14.0a1 (2012-03-23)
Device: Samsung Galaxy S
OS: Android 2.2

Possible steps to reproduce:
1. Open Fennec
2. Browse to any website
3. Tap on device Home button
4. Open stock browser

Expected result:
After step 4, bug 738633 will occur. Crash Reporter should not crash at this step.

Actual result:
E/GeckoCrashReporter( 9785): exception during send: 
E/GeckoCrashReporter( 9785): javax.net.ssl.SSLException: Not trusted server certificate
E/GeckoCrashReporter( 9785): 	at org.apache.harmony.xnet.provider.jsse.OpenSSLSocketImpl.startHandshake(OpenSSLSocketImpl.java:371)
E/GeckoCrashReporter( 9785): 	at org.apache.harmony.luni.internal.net.www.protocol.http.HttpConnection.getSecureSocket(HttpConnection.java:168)
E/GeckoCrashReporter( 9785): 	at org.apache.harmony.luni.internal.net.www.protocol.https.HttpsURLConnectionImpl$HttpsEngine.connect(HttpsURLConnectionImpl.java:399)
E/GeckoCrashReporter( 9785): 	at org.apache.harmony.luni.internal.net.www.protocol.http.HttpURLConnectionImpl.getOutputStream(HttpURLConnectionImpl.java:1253)
E/GeckoCrashReporter( 9785): 	at org.apache.harmony.luni.internal.net.www.protocol.https.HttpsURLConnectionImpl.getOutputStream(HttpsURLConnectionImpl.java:263)
E/GeckoCrashReporter( 9785): 	at org.mozilla.fennec.CrashReporter.sendReport(CrashReporter.java:258)
E/GeckoCrashReporter( 9785): 	at org.mozilla.fennec.CrashReporter.access$300(CrashReporter.java:69)
E/GeckoCrashReporter( 9785): 	at org.mozilla.fennec.CrashReporter$2.run(CrashReporter.java:170)
E/GeckoCrashReporter( 9785): 	at java.lang.Thread.run(Thread.java:1096)
E/GeckoCrashReporter( 9785): Caused by: java.security.cert.CertificateException: java.security.cert.CertPathValidatorException: TrustAnchor for CertPath not found.
E/GeckoCrashReporter( 9785): 	at org.apache.harmony.xnet.provider.jsse.TrustManagerImpl.checkServerTrusted(TrustManagerImpl.java:168)
E/GeckoCrashReporter( 9785): 	at org.apache.harmony.xnet.provider.jsse.OpenSSLSocketImpl.startHandshake(OpenSSLSocketImpl.java:366)
E/GeckoCrashReporter( 9785): 	... 8 more
E/GeckoCrashReporter( 9785): Caused by: java.security.cert.CertPathValidatorException: TrustAnchor for CertPath not found.
E/GeckoCrashReporter( 9785): 	at org.bouncycastle.jce.provider.PKIXCertPathValidatorSpi.engineValidate(PKIXCertPathValidatorSpi.java:149)
E/GeckoCrashReporter( 9785): 	at java.security.cert.CertPathValidator.validate(CertPathValidator.java:202)
E/GeckoCrashReporter( 9785): 	at org.apache.harmony.xnet.provider.jsse.TrustManagerImpl.checkServerTrusted(TrustManagerImpl.java:164)
E/GeckoCrashReporter( 9785): 	... 9 more
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 732629
You need to log in before you can comment on or make changes to this bug.