Videos can occasionally be in perpetually loading stage, even when you can play them fine

RESOLVED DUPLICATE of bug 738401

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 738401
6 years ago
6 years ago

People

(Reporter: wlach, Unassigned)

Tracking

13 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 608724 [details]
screenshot with some videos always loading

This seems to be a regression in Aurora 13: I didn't notice this on Aurora 12.

Basically, it seems like under certain circumstances, the video element will be in a perpetually loading stage. It seems to only happen when a video is added to the DOM dynamically, though I'm not 100% certain. I first noticed this here here:

http://wrla.ch/eideticker/dashboard/#/canvas

(click on one of the datapoints to get a video which reproduces the problem)

I tried to narrow down the problem with a standalone test case:

http://people.mozilla.com/~wlachance/video.html

If you click on the button repeatedly, eventually you'll get another video in the same state (see attached screenshot)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 738401
You need to log in before you can comment on or make changes to this bug.