Ludicrously Huge bookmarks.html file created

VERIFIED DUPLICATE of bug 74969

Status

SeaMonkey
Bookmarks & History
VERIFIED DUPLICATE of bug 74969
17 years ago
13 years ago

People

(Reporter: cyrus, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

Attachments

(6 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; 0.8.1)
BuildID:    032601

Starting mozilla seemed to be taking way too long, so I started poking around my
default profile and noticed this file:

-rw-r--r--  1 sly  staff  29868032 Mar 28 16:27 bookmarks.html

Lots and lots of dup bookmarks.

Reproducible: Didn't try

Running MacOSX 10.0

Comment 1

17 years ago
Possibly bug 69009 (or really bug 51021, I suppose)?

Comment 2

17 years ago
Another possible dup is bug 54866.

Comment 3

17 years ago
*** Bug 75760 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
*** Bug 75889 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
Created attachment 30823 [details]
Corrupt bookmarks file as requested by Timeless in 75760 (zipped, because Bugzilla choked when I sent it uncompressed)

Comment 6

17 years ago
*** Bug 76149 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
Did you ever import into this bookmarks file? I just ask because I'm trying to chase down
a common cause for all the bugs like this one I see

Comment 8

17 years ago
yes, i did import bookmark.htm (i have stored 4.x crucial files somewhere for
backup reasons) into 2001033009, but the same behavior appears even if no import
is done (clean install of 2001041104). as i said in dup 76149, only the default
bookmarks (mozzilla.org, ftp site, developer docs, RFCs) and personal toolbar
folder get written again and again upon every _closing_ of Moz.
*** Bug 77097 has been marked as a duplicate of this bug. ***
change OS to ALL (from the dupes: 1x Win2k, 1xLinux)
OS: MacOS X → All
Hardware: Macintosh → All

Comment 11

17 years ago
Created attachment 31792 [details]
gziped bookmarks.html

Comment 12

17 years ago
I can now reproduce this problem consistently.  Here are the steps:

- Start Mozilla (Linux 2001042122 rpms) with no bookmarks.html file
  Exit Mozilla - bookmarks.html is     5241 bytes
- Start Mozilla and import bookmark.html from old Mozilla (??? version)
  Exit Mozilla - bookmarks.html is    28652 bytes (book2)
- Start Mozilla and do nothing
  Exit Mozilla - bookmarks.html is    83676 bytes (book3)
- Start Mozilla and do nothing
  Exit Mozilla - bookmarks.html is   859404 bytes (book4)
- Start Mozilla and do nothing
  Exit Mozilla - bookmarks.html is 25822700 bytes

I will attach the three bookmark.html files named book2, book3, and book4 as
referenced above.

Comment 13

17 years ago
Created attachment 31796 [details]
bookmarks.html file just after importing old bookmarks.html

Comment 14

17 years ago
Created attachment 31797 [details]
bookmarks.html after opening/closing Mozilla once after import

Comment 15

17 years ago
Created attachment 31798 [details]
bookmarks.html after opening/closing Mozilla twice since import

Comment 16

17 years ago
Created attachment 31801 [details]
start of a bookmark file with self-replicating entry

Comment 17

17 years ago
I had a similar problem under windows, except that my bookmarks-file was deleted
after some restarting of mozilla (usually the last was a crash, I think)

It was also imported, but I don't think that was important (from french
navigator to englisch mozilla)

What happened was the following: One of my bookmarks had an 'ä' in it, and
somehow it was stored... you see in the attachment. And everytime i ran mozilla
this part of the link doubled in size, again, see the attachment. 
I think it is a problem with non-us-characters. 

Also, just to mention it, I got a mail with a filename with an 'é' in it. When i
went directly to "Save attachment" on the button, the name was correct, but when
I said open it, and then decided to save it, this character was replaced by
something strange... I see often strange things with foreign characters, but I'm
not sure if my settings are correct to report a bug for that. 

Comment 18

17 years ago
Just to add: This was the line in the bookmark file _before_ it was converted:

<A HREF="http://ahnenforschung.net/users/Bärecke.html" ADD_DATE="981426081"
LAST_VISIT="982023236" LAST_MODIFIED="981426064">Bärecke</A>             

Comment 19

17 years ago
"It was also imported, but I don't think that was important (from french
navigator to englisch mozilla)"

Ahh no, actually I believe that's exactly it. I believe this bug is a dupe of at least one bug
floating around out there that mentions import/ing.
Whiteboard: DUPEME

Comment 20

17 years ago
If you think it is important, then what do I do with a file that grows every
time I start mozilla? Is this then not considered a bug when mozilla treats it
incorrectly (and loses it later)?

Perhaps there is a bug in importing, but there is also a bug in the handling of
the bookmark file.

Importing is perhaps the way the bug is triggered now, but who knows what other
cases will happen?

Comment 21

17 years ago
I think I found a workaround for the bug. I deleted all the standard bookmarks
and emptied my Personal Toolbar Folder so that I have only my personal bookmarks
remaining. The bookmarks file has not grown ever since.

Comment 22

17 years ago
I'm seeing the same thing in win 32 build id: 2001042704
Twice today the bookmarks have grown to over 1 meg in just a few
hours of using this browser. I have not imported bookmarks but
did paste in old bookmarks.

Comment 23

17 years ago
adding cc

Comment 24

17 years ago
I just wanted to add that this behavior is also on a second machine
where the bookmarks have been copy via an mail and as I tried to 
start M 0.8.1 on it today it wouldn't start. Checking the profile folder
found a bookmark file of over 8 megs. The original file was 186 kbs

Comment 25

17 years ago
using win32 mtrunk installer build 2001043004.

i have never had this problem, because i have used the same bookmarks file since
m0.8.  it would appear importing is the real problem.  there is at least one bug
out there regarding importing that i can't seem to find now.

Comment 26

17 years ago
*** Bug 79410 has been marked as a duplicate of this bug. ***

Comment 27

17 years ago
to answer a question that came up earlier, the reason the import is the problem is that it
is creating a corrupted bookmark file. Mozilla then does stupid things with that corrupted
file and will continue to do so as long as you still have that file. It's hardly right to blame
Moz for choking on the corrupted file - although it would be nice to prevent that too.

I can't believe we haven't found the dupe yet...

Comment 28

17 years ago
well, i did some testing now with 0.9 milestone.
"corrupted" bookmarks kept growing. i renamed it and let mozilla create new
bookmark file. then i tried importing old file. yes, it was growing with every
closing of browser window (not only exiting Moz). i deleted it and let moz
create new one again. It never grew. Then i copied and pasted ONLY my personal
bookmarks into new bookmark file and it newer grew again. so, as i see the
problem: if there are mozilla default bookmarks in imported bookmark file, it
starts replicating them. i suggest a small implementation in importing utility:
to IGNORE browser's default bookmarks (and maybe personal toolbar, i didn't try
that one, tho) and imports personal bookmarks only.

Comment 29

17 years ago
This is a dupe of bug 74969.

Comment 30

17 years ago
according to bug # and discussion in bug 74969, i'd say it is other way around:)
we also found out, how it can be reproduced and figured out it has to do smth
with importing utility. but, i don't care. someone mark one of those two as a
dupe and fix the damn thing:)

Updated

17 years ago
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 31

17 years ago
Although I hate duping older bugs on newer ones I'm going to do it this time. The other
bug is assigned and has the right audience, plus that's where Ben's patches/comments are.


*** This bug has been marked as a duplicate of 74969 ***

Comment 32

17 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED

Comment 33

17 years ago
*** Bug 78935 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.