Closed Bug 738781 Opened 11 years ago Closed 11 years ago

Combobox dropdown persists across page load

Categories

(Core :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 676344

People

(Reporter: alice0775, Unassigned)

References

Details

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/ab2ff3b5611f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120323 Firefox/14.0a1 ID:20120323031214

Spun off from Bug 730694.
Combobox dropdown persists across page load. 

Reproducible: Always

Steps to reproduce:

1. Go to fanfic reviews page (http://www.fanfiction.net/r/5782108/17/1/)
2. In the top-right corner there is a drop-down box thing to select the chapter.
3. Click to make the drop-down list appear, and choose some random chapter.
4. The page will begin loading that page. before the page has loaded, click to drop-down again.

Actual results:
  The drop-down list will persist across the page-load

Expected results:
  The drop-down list should hide.

Regresion window
Cannot reproduce:
http://hg.mozilla.org/mozilla-central/rev/90d3e6d2cbb9
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090610 Minefield/3.6a1pre ID:20090610042525
Can reproduce:
http://hg.mozilla.org/mozilla-central/rev/4430cae50dad
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090611 Minefield/3.6a1pre ID:20090611044033
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=90d3e6d2cbb9&tochange=4430cae50dad

Last good : 71509552a2e
First bad : cabb8925dcd3
Regressed by:
cabb8925dcd3	Neil Deakin — Bug 178324, refactor focus by moving all focus handling into one place and simplifying it, add many tests, fixes many other bugs too numerous to mention in this small checkin comment, r=josh,smichaud,ere,dbaron,marco,neil,gavin,smaug,sr=smaug (CLOSED TREE)
Related to Bug 676344, Alice?
(In reply to XtC4UaLL [:xtc4uall] from comment #1)
> Related to Bug 676344, Alice?

Sure,
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.