Intermittent REFTEST TEST-UNEXPECTED-FAIL layout/base/crashtests/736924-1.html | assertion count 2 is more than expected 0 assertions

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

(Blocks 1 bug, {intermittent-failure})

14 Branch
x86
Windows 7
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

https://tbpl.mozilla.org/php/getParsedLog.php?id=10315377&tree=Firefox
Rev3 WINNT 6.1 mozilla-central debug test crashtest on 2012-03-23 06:59:21 PDT for push c20ec27eb0e8

REFTEST INFO | Loading a blank page
++DOMWINDOW == 91 (089C9B18) [serial = 2165] [outer = 052F0070]
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file e:/builds/moz2_slave/m-cen-w32-dbg/build/content/base/src/nsFrameLoader.cpp, line 419
++DOCSHELL 0E33F968 == 8 [id = 164]
++DOMWINDOW == 92 (0962C9E8) [serial = 2166] [outer = 00000000]
++DOMWINDOW == 93 (0905A100) [serial = 2167] [outer = 0962C998]
###!!! ASSERTION: This is unsafe! Fix the caller!: 'Error', file e:/builds/moz2_slave/m-cen-w32-dbg/build/content/events/src/nsEventDispatcher.cpp, line 559
xul!mozilla::scache::PathifyURI+0x000000000033E581
xul!mozilla::scache::PathifyURI+0x000000000046FEA5
xul!mozilla::scache::PathifyURI+0x000000000046FE46
xul!mozilla::scache::PathifyURI+0x0000000000247EFC
xul!mozilla::scache::PathifyURI+0x000000000024C3F1
xul!mozilla::scache::PathifyURI+0x00000000004632DB
xul!xpc_LocalizeContext+0x000000000011D3D7
xul!JSD_GetValueForObject+0x0000000000086F7E
xul!JSD_GetValueForObject+0x0000000000086FBA
xul!JSD_GetValueForObject+0x000000000008A1CF
xul!JSD_GetValueForObject+0x000000000008ACB3
xul!JSD_GetValueForObject+0x000000000008D873
xul!JSD_GetValueForObject+0x000000000008C20F
xul!CallWindowProcCrashProtected+0x000000000000001F
xul!JSD_GetValueForObject+0x000000000008CB8D
USER32!IsThreadDesktopComposited+0x000000000000011F
USER32!IsThreadDesktopComposited+0x00000000000002A6
USER32!InflateRect+0x0000000000000074
USER32!DefWindowProcW+0x0000000000000144
ntdll!KiUserCallbackDispatcher+0x000000000000002E
USER32!DefWindowProcW+0x00000000000000BD
USER32!DefWindowProcW+0x0000000000000054
USER32!GetWindowMinimizeRect+0x0000000000000324
USER32!DefWindowProcW+0x0000000000000144
ntdll!KiUserCallbackDispatcher+0x000000000000002E
xul!JSD_GetValueForObject+0x000000000009533D
xul!mozilla::scache::PathifyURI+0x00000000001F38F9
xul!mozilla::scache::PathifyURI+0x00000000001F52AE
xul!mozilla::scache::PathifyURI+0x00000000001F5175
xul!mozilla::scache::PathifyURI+0x00000000001F6E9A
xul!mozilla::scache::PathifyURI+0x00000000001F5138
xul!mozilla::scache::PathifyURI+0x00000000001F6E9A
xul!mozilla::scache::PathifyURI+0x00000000001F5138
xul!mozilla::scache::PathifyURI+0x00000000001F6E9A
xul!mozilla::scache::PathifyURI+0x00000000001F5138
xul!mozilla::scache::PathifyURI+0x00000000001F7B43
xul!mozilla::scache::PathifyURI+0x00000000001F7185
xul!mozilla::scache::PathifyURI+0x00000000001F547B
xul!mozilla::scache::PathifyURI+0x00000000001F4138
xul!mozilla::scache::PathifyURI+0x00000000001F89DF
xul!mozilla::scache::PathifyURI+0x00000000001F547B
xul!mozilla::scache::PathifyURI+0x00000000001F4138
xul!mozilla::scache::PathifyURI+0x00000000001F4FC6
xul!mozilla::scache::PathifyURI+0x00000000000FEA19
xul!mozilla::scache::PathifyURI+0x00000000001562CB
xul!mozilla::scache::PathifyURI+0x00000000000C9C1E
xul!mozilla::scache::PathifyURI+0x00000000000CD6B2
xul!mozilla::scache::PathifyURI+0x00000000000CDA33
xul!mozilla::scache::PathifyURI+0x00000000000CF516
xul!XRE_AddJarManifestLocation+0x0000000000009A53
xul!XRE_AddJarManifestLocation+0x0000000000009B9D
xul!XRE_AddJarManifestLocation+0x0000000000005B83
xul!JSD_GetValueForObject+0x0000000000267179
xul!xpc_LocalizeContext+0x000000000011904D
xul!xpc_LocalizeContext+0x0000000000115A4F
xul!xpc_LocalizeContext+0x0000000000128852
xul!xpc_LocalizeContext+0x00000000000ECCE3
xul!xpc_LocalizeContext+0x00000000000EE421
xul!mozilla::scache::PathifyURI+0x000000000047BE15
xul!mozilla::scache::PathifyURI+0x000000000047B9B6
xul!mozilla::scache::PathifyURI+0x000000000047DBF3
xul!NS_InvokeByIndex_P+0x0000000000000027
xul!xpc_LocalizeContext+0x000000000000D610
xul!xpc_LocalizeContext+0x0000000000011156
xul!xpc_LocalizeContext+0x0000000000011535
xul!xpc_LocalizeContext+0x0000000000013ABD
mozjs!js_ValueToSource+0x00000000000F2F1C
mozjs!js_ValueToSource+0x00000000000F92E8
mozjs!js_ValueToSource+0x00000000000FD3FB
mozjs!js_ValueToSource+0x00000000000F5B00
mozjs!js_ValueToSource+0x00000000000F937E
mozjs!js_ValueToSource+0x00000000000F5C7F
mozjs!js_ValueToSource+0x000000000003EF69
xul!mozilla::scache::PathifyURI+0x000000000045C003
xul!mozilla::scache::PathifyURI+0x000000000047E8C3
xul!mozilla::scache::PathifyURI+0x000000000047EBC8
xul!XRE_AddJarManifestLocation+0x0000000000009A48
xul!XRE_AddJarManifestLocation+0x0000000000009B9D
xul!XRE_AddJarManifestLocation+0x0000000000005B83
xul!JSD_GetValueForObject+0x0000000000267179
xul!JSD_GetValueForObject+0x0000000000185E0F
xul!StartupHooker+0x0000000000013835
xul!StartupHooker+0x0000000000013D72
xul!StartupHooker+0x000000000001423D
xul!JSD_GetValueForObject+0x00000000000C1267
xul!JSD_GetValueForObject+0x0000000000090525
xul!xpc_LocalizeContext+0x00000000001280F7
xul!XRE_main+0x0000000000001D80
firefox!mozilla::detail::GuardObjectNotificationReceiver::GuardObjectNotificationReceiver+0x0000000000000ADE
firefox!mozilla::detail::GuardObjectNotificationReceiver::GuardObjectNotificationReceiver+0x0000000000000D01
firefox!mozilla::detail::GuardObjectNotificationReceiver::GuardObjectNotificationReceiver+0x0000000000000E70
firefox!mozilla::detail::GuardObjectNotificationReceiver::GuardObjectNotificationReceiver+0x0000000000004294
firefox!mozilla::detail::GuardObjectNotificationReceiver::GuardObjectNotificationReceiver+0x00000000000040C4
kernel32!BaseThreadInitThunk+0x0000000000000012
ntdll!RtlInitializeExceptionChain+0x0000000000000063
ntdll!RtlInitializeExceptionChain+0x0000000000000036
###!!! ASSERTION: This is unsafe! Fix the caller!: 'Error', file e:/builds/moz2_slave/m-cen-w32-dbg/build/content/events/src/nsEventDispatcher.cpp, line 559
xul!mozilla::scache::PathifyURI+0x000000000033E581
xul!mozilla::scache::PathifyURI+0x000000000046FEA5
xul!mozilla::scache::PathifyURI+0x000000000046FE46
xul!mozilla::scache::PathifyURI+0x0000000000247EFC
xul!mozilla::scache::PathifyURI+0x000000000024C3F1
xul!mozilla::scache::PathifyURI+0x000000000046308A
xul!xpc_LocalizeContext+0x000000000011D1B9
xul!JSD_GetValueForObject+0x0000000000086F7E
xul!JSD_GetValueForObject+0x0000000000086FBA
xul!JSD_GetValueForObject+0x000000000008A1CF
xul!JSD_GetValueForObject+0x000000000008ACB3
xul!JSD_GetValueForObject+0x000000000008D873
xul!JSD_GetValueForObject+0x000000000008C20F
xul!CallWindowProcCrashProtected+0x000000000000001F
xul!JSD_GetValueForObject+0x000000000008CB8D
USER32!IsThreadDesktopComposited+0x000000000000011F
USER32!IsThreadDesktopComposited+0x00000000000002A6
USER32!InflateRect+0x0000000000000074
USER32!DefWindowProcW+0x0000000000000144
ntdll!KiUserCallbackDispatcher+0x000000000000002E
USER32!DefWindowProcW+0x00000000000000BD
USER32!DefWindowProcW+0x0000000000000054
USER32!IsThreadDesktopComposited+0x000000000000011F
USER32!IsThreadDesktopComposited+0x00000000000002A6
USER32!WindowFromDC+0x00000000000000EB
USER32!CallWindowProcW+0x000000000000001B
xul!JSD_GetValueForObject+0x000000000008C238
xul!CallWindowProcCrashProtected+0x000000000000001F
xul!JSD_GetValueForObject+0x000000000008CB8D
USER32!IsThreadDesktopComposited+0x000000000000011F
USER32!IsThreadDesktopComposited+0x00000000000002A6
USER32!InflateRect+0x0000000000000074
USER32!DefWindowProcW+0x0000000000000144
ntdll!KiUserCallbackDispatcher+0x000000000000002E
xul!JSD_GetValueForObject+0x000000000009533D
xul!mozilla::scache::PathifyURI+0x00000000001F38F9
xul!mozilla::scache::PathifyURI+0x00000000001F52AE
xul!mozilla::scache::PathifyURI+0x00000000001F5175
xul!mozilla::scache::PathifyURI+0x00000000001F6E9A
xul!mozilla::scache::PathifyURI+0x00000000001F5138
xul!mozilla::scache::PathifyURI+0x00000000001F6E9A
xul!mozilla::scache::PathifyURI+0x00000000001F5138
xul!mozilla::scache::PathifyURI+0x00000000001F6E9A
xul!mozilla::scache::PathifyURI+0x00000000001F5138
xul!mozilla::scache::PathifyURI+0x00000000001F7B43
xul!mozilla::scache::PathifyURI+0x00000000001F7185
xul!mozilla::scache::PathifyURI+0x00000000001F547B
xul!mozilla::scache::PathifyURI+0x00000000001F4138
xul!mozilla::scache::PathifyURI+0x00000000001F89DF
xul!mozilla::scache::PathifyURI+0x00000000001F547B
xul!mozilla::scache::PathifyURI+0x00000000001F4138
xul!mozilla::scache::PathifyURI+0x00000000001F4FC6
xul!mozilla::scache::PathifyURI+0x00000000000FEA19
xul!mozilla::scache::PathifyURI+0x00000000001562CB
xul!mozilla::scache::PathifyURI+0x00000000000C9C1E
xul!mozilla::scache::PathifyURI+0x00000000000CD6B2
xul!mozilla::scache::PathifyURI+0x00000000000CDA33
xul!mozilla::scache::PathifyURI+0x00000000000CF516
xul!XRE_AddJarManifestLocation+0x0000000000009A53
xul!XRE_AddJarManifestLocation+0x0000000000009B9D
xul!XRE_AddJarManifestLocation+0x0000000000005B83
xul!JSD_GetValueForObject+0x0000000000267179
xul!xpc_LocalizeContext+0x000000000011904D
xul!xpc_LocalizeContext+0x0000000000115A4F
xul!xpc_LocalizeContext+0x0000000000128852
xul!xpc_LocalizeContext+0x00000000000ECCE3
xul!xpc_LocalizeContext+0x00000000000EE421
xul!mozilla::scache::PathifyURI+0x000000000047BE15
xul!mozilla::scache::PathifyURI+0x000000000047B9B6
xul!mozilla::scache::PathifyURI+0x000000000047DBF3
xul!NS_InvokeByIndex_P+0x0000000000000027
xul!xpc_LocalizeContext+0x000000000000D610
xul!xpc_LocalizeContext+0x0000000000011156
xul!xpc_LocalizeContext+0x0000000000011535
xul!xpc_LocalizeContext+0x0000000000013ABD
mozjs!js_ValueToSource+0x00000000000F2F1C
mozjs!js_ValueToSource+0x00000000000F92E8
mozjs!js_ValueToSource+0x00000000000FD3FB
mozjs!js_ValueToSource+0x00000000000F5B00
mozjs!js_ValueToSource+0x00000000000F937E
mozjs!js_ValueToSource+0x00000000000F5C7F
mozjs!js_ValueToSource+0x000000000003EF69
xul!mozilla::scache::PathifyURI+0x000000000045C003
xul!mozilla::scache::PathifyURI+0x000000000047E8C3
xul!mozilla::scache::PathifyURI+0x000000000047EBC8
xul!XRE_AddJarManifestLocation+0x0000000000009A48
xul!XRE_AddJarManifestLocation+0x0000000000009B9D
xul!XRE_AddJarManifestLocation+0x0000000000005B83
xul!JSD_GetValueForObject+0x0000000000267179
xul!JSD_GetValueForObject+0x0000000000185E0F
xul!StartupHooker+0x0000000000013835
xul!StartupHooker+0x0000000000013D72
xul!StartupHooker+0x000000000001423D
xul!JSD_GetValueForObject+0x00000000000C1267
xul!JSD_GetValueForObject+0x0000000000090525
xul!xpc_LocalizeContext+0x00000000001280F7
xul!XRE_main+0x0000000000001D80
firefox!mozilla::detail::GuardObjectNotificationReceiver::GuardObjectNotificationReceiver+0x0000000000000ADE
firefox!mozilla::detail::GuardObjectNotificationReceiver::GuardObjectNotificationReceiver+0x0000000000000D01
firefox!mozilla::detail::GuardObjectNotificationReceiver::GuardObjectNotificationReceiver+0x0000000000000E70
firefox!mozilla::detail::GuardObjectNotificationReceiver::GuardObjectNotificationReceiver+0x0000000000004294
firefox!mozilla::detail::GuardObjectNotificationReceiver::GuardObjectNotificationReceiver+0x00000000000040C4
kernel32!BaseThreadInitThunk+0x0000000000000012
ntdll!RtlInitializeExceptionChain+0x0000000000000063
ntdll!RtlInitializeExceptionChain+0x0000000000000036
WARNING: Subdocument container has no frame: file e:/builds/moz2_slave/m-cen-w32-dbg/build/layout/base/nsDocumentViewer.cpp, line 2442
++DOMWINDOW == 94 (08CC44E8) [serial = 2168] [outer = 08CC2C38]
WARNING: Subdocument container has no frame: file e:/builds/moz2_slave/m-cen-w32-dbg/build/layout/base/nsDocumentViewer.cpp, line 2442
++DOMWINDOW == 95 (08CC4F10) [serial = 2169] [outer = 08CC3868]
++DOMWINDOW == 96 (186805B0) [serial = 2170] [outer = 0962C998]
REFTEST TEST-START | file:///c:/talos-slave/test/build/reftest/tests/layout/base/crashtests/736924-1.html | 906 / 2033 (44%)
++DOMWINDOW == 97 (0905A4F0) [serial = 2171] [outer = 0962C998]
WARNING: Nv3DVStreaming CoCreateInstance failed (disabled).: file e:/builds/moz2_slave/m-cen-w32-dbg/build/gfx/layers/d3d9/Nv3DVUtils.cpp, line 85
WARNING: NS_ENSURE_TRUE(mMutable) failed: file e:/builds/moz2_slave/m-cen-w32-dbg/build/netwerk/base/src/nsSimpleURI.cpp, line 293
++DOMWINDOW == 98 (1867DE50) [serial = 2172] [outer = 052F0070]
--DOCSHELL 0B23C498 == 7 [id = 160]
WARNING: getting z level of unregistered window: file e:/builds/moz2_slave/m-cen-w32-dbg/build/xpfe/appshell/src/nsWindowMediator.cpp, line 595
WARNING: getting z level of unregistered window: file e:/builds/moz2_slave/m-cen-w32-dbg/build/xpfe/appshell/src/nsWindowMediator.cpp, line 595
WARNING: NS_ENSURE_SUCCESS(rv, false) failed with result 0x8000FFFF: file e:/builds/moz2_slave/m-cen-w32-dbg/build/content/base/src/nsContentUtils.cpp, line 2877
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file e:/builds/moz2_slave/m-cen-w32-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 358
--DOCSHELL 1822DE00 == 6 [id = 162]
WARNING: NS_ENSURE_SUCCESS(rv, false) failed with result 0x8000FFFF: file e:/builds/moz2_slave/m-cen-w32-dbg/build/content/base/src/nsContentUtils.cpp, line 2877
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file e:/builds/moz2_slave/m-cen-w32-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 358
WARNING: NS_ENSURE_SUCCESS(rv, false) failed with result 0x8000FFFF: file e:/builds/moz2_slave/m-cen-w32-dbg/build/content/base/src/nsContentUtils.cpp, line 2877
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file e:/builds/moz2_slave/m-cen-w32-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 358
--DOCSHELL 1822BE10 == 5 [id = 163]
WARNING: NS_ENSURE_SUCCESS(rv, false) failed with result 0x8000FFFF: file e:/builds/moz2_slave/m-cen-w32-dbg/build/content/base/src/nsContentUtils.cpp, line 2877
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file e:/builds/moz2_slave/m-cen-w32-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 358
WARNING: NS_ENSURE_SUCCESS(rv, false) failed with result 0x8000FFFF: file e:/builds/moz2_slave/m-cen-w32-dbg/build/content/base/src/nsContentUtils.cpp, line 2877
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file e:/builds/moz2_slave/m-cen-w32-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 358
WARNING: NS_ENSURE_SUCCESS(rv, false) failed with result 0x8000FFFF: file e:/builds/moz2_slave/m-cen-w32-dbg/build/content/base/src/nsContentUtils.cpp, line 2877
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file e:/builds/moz2_slave/m-cen-w32-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 358
REFTEST TEST-PASS | file:///c:/talos-slave/test/build/reftest/tests/layout/base/crashtests/736924-1.html | (LOAD ONLY)
REFTEST INFO | Loading a blank page
++DOMWINDOW == 99 (1867EA20) [serial = 2173] [outer = 052F0070]
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/base/crashtests/736924-1.html | assertion count 2 is more than expected 0 assertions
https://tbpl.mozilla.org/php/getParsedLog.php?id=10323736&tree=Mozilla-Inbound
Rev3 WINNT 6.1 mozilla-inbound debug test crashtest on 2012-03-23 12:16:30 PDT for push 52825f4226e6
CPG seems to have increased the frequency of this to near perma-orange.

I've retriggered a load of them before and after CPG landed, to confirm it was indeed the cause. Page down a number of times on here to see the results when they come through:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&jobname=Rev3%20WINNT%206.1%20mozilla-inbound%20debug%20test%20crashtest
Blocks: cpg
Given that:
 1. the test failed intermittently before and doesn't always fail after cpg
 2. the failure is not a crash or otherwise indicating corruption
 3. cpg tends to cause all-or-nothing failures (timing independent)
 4. cpg does, however, affect timing
I would think that there is a bug (timing or order dependence) in the test which is getting exacerbated by cpg.

Based on this, can we disable the test and file a bug to reenable?
You don't need to disable it, it's "just" assertions, you just annotate them in http://mxr.mozilla.org/mozilla-central/source/layout/base/crashtests/crashtests.list#357. Just assertions about how windows theme code is spinning the event loop during reflow, according to khuey's read of ted unscrewingup of the stack in http://pastebin.mozilla.org/1614805, which is apparently both "unsafe!" and a Very Bad Thing.
Based on the stack in comment 92, khuey says this is a bug in windows theme code.
Yeah this is pretty broken.  QueryForButtonData causes a titlebar update, which creates and destroys a window which means that the native event loop is spun.  That's very very bad during reflow.

http://pastebin.mozilla.org/1614896
No longer blocks: cpg
Annotated in https://hg.mozilla.org/integration/mozilla-inbound/rev/e2f1d7d2a011
Whiteboard: [orange] → [orange][please leave open]
Handing to jimm to fix or find an owner.
Assignee: nobody → jmathies
Blocks: 812346
Whiteboard: [orange][please leave open] → [please leave open]
Assignee: jmathies → nobody
Testcase no longer asserts on trunk.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: in-testsuite+
Resolution: --- → WORKSFORME
Whiteboard: [please leave open]
removing the b2g 2.5 flag since this commit has been reverted due to an incorrect merge, sorry for the confusion
You need to log in before you can comment on or make changes to this bug.