Closed Bug 738824 Opened 12 years ago Closed 11 years ago

write tegra pool library webapp

Categories

(Release Engineering :: General, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 821400

People

(Reporter: mozilla, Unassigned)

References

Details

Requirements:

* Keep a list of all available Tegras.
** Tegra name
** IP
** FQDN may be needed but we'll see.
* Most likely need to support Pandas and other device types as well.
** Need to be able to differentiate between these.
* Ability to check these in/out
** Checking in a tegra will mark it available for checking out.
** Checking out a tegra will mark it unavailable for use.
*** Need to record a timestamp, who checked it out, possibly TTL for the reservation.
* Ability to mark a tegra as bad or good with timestamp and comment.
** Need to keep a history of these as well as current status.
** Ability to add manual comments would be good too.  (e.g. automatically mark tegra X as "needing investigation"; manually investigate and comment with resolution)
** Bad tegras are never available for checking out.
* Some form of reporting (x tegras are available for use; y are in use; z are marked bad.  This list of tegras were checked out and never checked in; it's past their TTL)
* Need a way to reserve a device for the next run.
** This is a way to say "finish what you're doing, but afterwards, take it out of service so I can do something specific with it".  Maintenance, staging tests, w/e.
Blocks: 772959
This sounds exactly like our combined work [mozpool/lifeguard/bmm/etc.], is this a bug we should make to a tracker for that work, dupe some of that work over to this bug, or dupe the bug forward to where work is happening?
I think the initial rollout of mozpool is targeting pandas.
If we're covering tegras as well, then yes, we can dup.
I think it will cover tegras eventually -- at any rate, it won't make sense to re-implement something similar for tegras.
Yeah, we're focussing on b2g with mozpool right now, but I'm keeping other use cases in mind. Shouldn't need too many changes to support tegras when we get there.
Right.
I think we can close the mozpool bugs when pandas are fully supported; we should have a bug to track supporting tegras.  This can be that bug, or some other bug can be that bug, but we should have one.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.