Regression: wrong rendering of https://www.archlinux.org/visualize/

RESOLVED FIXED

Status

defect
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: thomas-lange2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Posted image Screenshot.png
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120323 Firefox/13.0a2 Aurora/13.0a2
Build ID: 20120323003610

Steps to reproduce:

Visited https://www.archlinux.org/visualize/


Actual results:

Wrong rendering of "Visualization of PGP Master and Signing Keys"
Screenshot attached


Expected results:

Visualization should be rendered correctly.
Reproduced with Firefox 11 and Aurora 13.0a2.

Comment 1

7 years ago
Confirmed on Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20120323 Firefox/14.0a1 ID:20120323031214

Thomas -> Think you could track down a regression window? -> http://harthur.github.com/mozregression/
Version: 13 Branch → Trunk

Updated

7 years ago
Blocks: 611099

Comment 2

7 years ago
Maybe duplicate of Bug 736431
It is indeed.

NOTE: If I use the page inspector to view the rules on the SVG area, and select the <svg> node and add the style "height: 100%" to its selector ("#visualize-keys svg"), then the site renders as expected.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 736431
I emailed the developers whose names/contact info are given at the bottom of that page, with the suggested change -- adding "height: 100%" to the  "#visualize-keys svg" style rule here:
https://www.archlinux.org/static/archweb.css
Component: Untriaged → SVG
Product: Firefox → Core
QA Contact: untriaged → general
Got a pretty quick response from Dan McGee, who has fixed the site. (The CSS has the line suggested in comment 4, and the rendering is now correct in my Nightly at least.) Awesome!

Reclassifying as Tech Evang. & resolving as FIXED (as the site has now been updated).
Assignee: nobody → english-us
Component: SVG → English US
Product: Core → Tech Evangelism
QA Contact: general → english-us
Resolution: DUPLICATE → FIXED
Version: Trunk → unspecified
For reference: see also bug 736431 (and bug 736431 comment 12 in particular).

(If this weren't a Tech Evang bug, it'd be a dupe of that bug.)
(Ah, and I guess that's the bug I'd originally duped this to in Comment 3. Good sleuthing, week-ago-me!)
(er, good sleuthing to Alice0775 White, rather.)
(done posting on this bug now, sorry for the spam)
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.