Status

()

RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: kdevel, Unassigned)

Tracking

({perf, regression})

Trunk
x86_64
Linux
perf, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-would-take])

(Reporter)

Description

7 years ago
User Agent:  

Steps to reproduce:

1. Open http://www.spiegel.de/ (A).
2. Click at Link named "Liberale hoffen auf das Lindner-Wunder". (B)
3. Click at back button. 
4. Repeat with STR #2 a few times rapidly.


Actual results:

A -- blank screen for some fractions of a second -- B


Expected results:

A -- B

last good nightly 2012-03-23-03-12-14-mozilla-central ab2ff3b5611f
first bad nightly 2012-03-24-03-11-00-mozilla-central df1f94b2bdee
(Reporter)

Updated

7 years ago
OS: Other → Linux
Hardware: Other → x86_64
(Reporter)

Comment 1

7 years ago
The issue can be reproduced with the current headline (just now it is "CDU siegt im Saarland - Piraten entern Landtag").

The first bad revision is:
changeset: 90110:87ea59a6d162
user: Patrick McManus <mcmanus@ducksong.com>
date: Thu Mar 22 19:39:31 2012 -0400
summary: bug 603512 - large objects block pipelines r=honzab

Updated

5 years ago
Blocks: 603512
Keywords: perf
stefan - are you using a clean profile on desktop or have you turned on http pipelining?

if you can help me with a fresh STR that would be helpful - the links on that page aren't there anymore.
(Reporter)

Comment 3

5 years ago
- I am using a special profile, cannot reproduce the issue with a clean profile.
- pipelining is off
- STR is unchanged, try with the current headline "Fukushimas strahlende Wassermassen" and with FF 20. It seems that before the page ist loaded the viewport is cleared (white). It flickers when it loads. ESR 17.0.7 is okay.

I will bisect the profile.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

5 years ago
Ooops.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

5 years ago
(In reply to Stefan from comment #3)
> - I am using a special profile, cannot reproduce the issue with a clean
> profile.

What is a "special profile"?
Did you manage to bisect?
Flags: needinfo?(kdevel)
(Reporter)

Comment 6

5 years ago
(In reply to Andre Klapper from comment #5)
> What is a "special profile"?
> Did you manage to bisect?

Today I can reproduce the issue with a new (clean) profile using the current headline link ‘Obamas Appell an Republikaner: "Stoppen Sie diese Farce"‘
Flags: needinfo?(kdevel)

Comment 7

5 years ago
Okay, but my questions were:

> What is a "special profile"?
> Did you manage to bisect?
Flags: needinfo?(kdevel)
(Reporter)

Comment 8

5 years ago
(In reply to Andre Klapper from comment #7)
> Okay, but my questions were:
> 
> > What is a "special profile"?

A profile which has grown over the years.

> > Did you manage to bisect?

I did not try to for I could reproduce the issue with a clean profile.
Flags: needinfo?(kdevel)
(Reporter)

Comment 9

4 years ago
Persists in Firefox 28

Updated

3 years ago
Component: Untriaged → Networking: HTTP
Keywords: regression
Product: Firefox → Core
Whiteboard: [necko-would-take]
This bug has been tagged for Regression and or closure.
I am setting this to New. I can reproduce this in Ubuntu and Windows 10
1) Access http://www.spiegel.de/
2) Click link for English for ease of reading
3) Click the link for the top headline 
4) Click Arrow to go back 1 page 
5) Click the Arrow to go forward one page
Observe: site is slow and white pages can be seen throughout
Tested with Clean Profile in Ubuntu 14.04 and Windows 10 on Nightly channel
Tested manipulation of the network.http.pipelining 
Version 	48.0a1
Build ID 	20160406030221
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Version 	48.0a1
Build ID 	20160404030231
User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Michelle, please clarify your test and what manipulation of network.http.pipelining means. If it simply means it is slower with one setting than the other that might not be surprising.
Yes, and also please state why this should be a regression caused by the networking code.
@Wayne, can you answer comment #12?
Flags: needinfo?(vseerror)

Comment 14

3 years ago
(In reply to Honza Bambas (:mayhemer) from comment #12)
> Yes, and also please state why this should be a regression caused by the
> networking code.

I can'tsay why this might be a regresion of networking code. Also, I didn't personally test.
I merely coded "regression" keyword based on comment 0
Flags: needinfo?(vseerror)
Clarity from QA: 
Regression keyword already existed when I tested and posted notes - ref: Comment 10.
Also I do not know what lead to the keyword getting applied.
Also Yes, comment 11 answers the pipelining - One setting was slower than the other.
this is essentially a pipelining tuning bug (some cases got better, some got worse) and pipelining is disabled by default and superceded by http/2 - that's where we will put the effort.

thanks for the explanation
Status: NEW → RESOLVED
Last Resolved: 5 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.