Last Comment Bug 738975 - Speed up building of layout/svg/base/src by dropping content/html/content/src from the include path
: Speed up building of layout/svg/base/src by dropping content/html/content/src...
Status: RESOLVED FIXED
[include-what-you-use]
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13)
:
Mentors:
Depends on:
Blocks: 738969 iwyu
  Show dependency treegraph
 
Reported: 2012-03-24 12:35 PDT by Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13)
Modified: 2013-08-11 03:18 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.84 KB, patch)
2012-03-24 12:35 PDT, Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13)
bzbarsky: review+
Details | Diff | Review

Description Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13) 2012-03-24 12:35:45 PDT
Created attachment 609029 [details] [diff] [review]
patch

One more step towards fixing bug 738969 is dropping content/html/content/src from the include path for layout/svg/base/src. The only reason we need it is because nsImageLoadingContent.h unnecessarily includes nsGenericHTMLElement.h.

This patch drops nsGenericHTMLElement.h and other unnecessary headers from the include directives in nsImageLoadingContent.h and remove content/html/content/src from the include paths for layout/svg/base/src.

This small change reduces the warm |make -B| build time for layout/svg/base/src by about 1.1% for me.

bz: see bug 738969 comment 0 for background.
Comment 1 Boris Zbarsky [:bz] (Out June 25-July 6) 2012-03-25 12:52:12 PDT
Comment on attachment 609029 [details] [diff] [review]
patch

r=me
Comment 2 Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13) 2012-03-26 05:02:41 PDT
Pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/df36e7f3aba4
Comment 3 Matt Brubeck (:mbrubeck) 2012-03-26 11:30:55 PDT
https://hg.mozilla.org/mozilla-central/rev/df36e7f3aba4

Note You need to log in before you can comment on or make changes to this bug.