Closed Bug 738992 Opened 9 years ago Closed 8 years ago

Intermittent netwerk/test/browser/browser_NetUtil.js | request succeeded and a time out

Categories

(Core :: Networking, defect)

All
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: RyanVM, Unassigned)

References

Details

(Keywords: intermittent-failure)

https://tbpl.mozilla.org/php/getParsedLog.php?id=10350770&tree=Mozilla-Inbound&full=1

Rev3 Fedora 12x64 mozilla-inbound pgo test mochitest-other on 2012-03-24 12:44:43 PDT for push 2342271b2be1

builder: mozilla-inbound_fedora64_test_pgo-mochitest-other
slave: talos-r3-fed64-058
starttime: 1332618283.38
results: warnings (1)
buildid: 20120324090002
builduid: 1c4b010ed08a44fc806fa902dabbabb3
revision: 2342271b2be1

TEST-START | chrome://mochitests/content/browser/netwerk/test/browser/browser_NetUtil.js
TEST-PASS | chrome://mochitests/content/browser/netwerk/test/browser/browser_NetUtil.js | request failed
TEST-PASS | chrome://mochitests/content/browser/netwerk/test/browser/browser_NetUtil.js | request is an nsIHttpChannel
TEST-PASS | chrome://mochitests/content/browser/netwerk/test/browser/browser_NetUtil.js | cert error dialog was not shown
TEST-PASS | chrome://mochitests/content/browser/netwerk/test/browser/browser_NetUtil.js | request failed
TEST-PASS | chrome://mochitests/content/browser/netwerk/test/browser/browser_NetUtil.js | request is an nsIHttpChannel
TEST-PASS | chrome://mochitests/content/browser/netwerk/test/browser/browser_NetUtil.js | cert error dialog was not shown
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/netwerk/test/browser/browser_NetUtil.js | request succeeded
Stack trace:
    JS frame :: chrome://mochitests/content/browser/netwerk/test/browser/browser_NetUtil.js :: <TOP_LEVEL> :: line 64
    JS frame :: resource://gre/modules/NetUtil.jsm :: <TOP_LEVEL> :: line 174

TEST-PASS | chrome://mochitests/content/browser/netwerk/test/browser/browser_NetUtil.js | request is an nsIHttpChannel
TEST-INFO | chrome://mochitests/content/browser/netwerk/test/browser/browser_NetUtil.js | Console message: [JavaScript Error: "[Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIHttpChannel.requestSucceeded]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: chrome://mochitests/content/browser/netwerk/test/browser/browser_NetUtil.js :: <TOP_LEVEL> :: line 66"  data: no]" {file: "chrome://mochitests/content/browser/netwerk/test/browser/browser_NetUtil.js" line: 66}]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/netwerk/test/browser/browser_NetUtil.js | Test timed out
Evidently the "valid request" is failing for some reason... I added some logging to determine with what nsresult:

https://hg.mozilla.org/integration/mozilla-inbound/rev/69b20b2d47f1
So the latest logs show the request is failing with NS_ERROR_NET_RESET. bsmith, do you know why this might be happening in our test environment, or what could cause this to happen in general?
Patrick may have some ideas re: comment 31 too.
Perhaps this is caused by false-positive TLS intolerance like bug 749890. After bug 749890 is fixed, let's see if this this still happens.
Depends on: 749890
Whiteboard: [orange]
Resolving WFM keyword:intermittent-failure bugs last modified >3 months ago, whose whiteboard contains none of:
{random,disabled,marked,fuzzy,todo,fails,failing,annotated,time-bomb,leave open}

There will inevitably be some false positives; for that (and the bugspam) I apologise. Filter on orangewfm.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.