Closed Bug 738995 Opened 9 years ago Closed 9 years ago

[10.7] closing a window in Lion full screen mode leaves the user on an empty Space for a few seconds

Categories

(Core :: Widget: Cocoa, defect)

x86
macOS
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 757618

People

(Reporter: asqueella, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: polish, Whiteboard: [parity-safari] [parity-chrome])

Nightly, clean profile.

STR:
1. Open Firefox
2. Enter full-screen mode by clicking the Lion full-screen button or via Cmd+Shift+F
3. Cmd+N to create a new window (this is glitchy - see bug 738993)
4. Cmd+W to close the window.

Actual results: An empty full-screen space, which is destroyed after 5-10 seconds and the user is switched to another space.

Expected results: like Safari and Chrome, destroy the empty space immediately and (unlike them) switch to a previous window if it exists.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 757618
You need to log in before you can comment on or make changes to this bug.