Closed Bug 739027 Opened 8 years ago Closed 8 years ago

crash in nsXPConnect::Push

Categories

(Core :: XPConnect, defect, critical)

14 Branch
x86
Windows NT
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 741056
Tracking Status
firefox14 - ---

People

(Reporter: scoobidiver, Unassigned)

References

Details

(Keywords: crash, regression, topcrash)

Crash Data

It first appeared in 14.0a1/20120324 and is currently #7 top crasher in 14.0a1 over the last day.
The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ab2ff3b5611f&tochange=df1f94b2bdee

Signature 	MOZ_Crash More Reports Search
UUID	86633383-842b-41ff-bf50-71d2b2120325
Date Processed	2012-03-25 06:40:08
Uptime	27
Last Crash	5.1 minutes before submission
Install Age	52.7 minutes since version was first installed.
Install Time	2012-03-25 06:50:04
Product	Firefox
Version	14.0a1
Build ID	20120324031100
Release Channel	nightly
OS	Windows NT
OS Version	5.1.2600 Service Pack 2
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 23 stepping 10
Crash Reason	EXCEPTION_ACCESS_VIOLATION_WRITE
Crash Address	0x0
App Notes 	
AdapterVendorID: 0x8086, AdapterDeviceID: 0x29c2, AdapterSubsysID: 00000000, AdapterDriverVersion: 6.14.10.5029
D3D10 Layers? D3D10 Layers- D3D9 Layers? D3D9 Layers- 
EMCheckCompatibility	True	
Total Virtual Memory	2147352576
Available Virtual Memory	1970843648
System Memory Use Percentage	24
Available Page File	3776618496
Available Physical Memory	1613959168

Frame 	Module 	Signature [Expand] 	Source
0 	mozglue.dll 	MOZ_Crash 	mfbt/Assertions.cpp:70
1 	mozglue.dll 	MOZ_Assert 	mfbt/Assertions.cpp:88
2 	xul.dll 	nsXPConnect::Push 	js/xpconnect/src/nsXPConnect.cpp:2558
3 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:622
4 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
5 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:201
6 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:175
7 	xul.dll 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:189
8 	xul.dll 	nsAppShell::Run 	widget/windows/nsAppShell.cpp:267
9 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:295
10 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3703
11 	msvcr100.dll 	msvcr100.dll@0x8b581 	
12 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:107
13 	msvcr100.dll 	_initterm 	f:\\dd\\vctools\\crt_bld\\self_x86\\crt\\src\\crt0dat.c:872
14 	firefox.exe 	__tmainCRTStartup 	crtexe.c:552
15 	firefox.exe 	_SEH_epilog4 	
16 	kernel32.dll 	BaseProcessStart 	
17 	kernel32.dll 	GetCodePageFileInfo 	
18 	kernel32.dll 	BaseProcessStart 	
19 	firefox.exe 	pre_c_init 	crtexe.c:261 

More reports at:
https://crash-stats.mozilla.com/report/list?signature=MOZ_Crash
Looks like a threading problem. Have you seen this, Bobby? I'm pretty sure it's this assertion:
  http://mxr.mozilla.org/mozilla-central/source/js/xpconnect/src/xpcprivate.h#3698
Blocks: 716167
This stack doesn't seem to make sense - it certainly appears that it's on the main thread, and the crashing code is asserting just that...
Here are some addon and module manual correlations I dug up:

MOZ_Crash|EXCEPTION_ACCESS_VIOLATION_WRITE (60 crashes)
     15% (9/60) vs.   4% (47/1085) {8620c15f-30dc-4dba-a131-7c5d20cf4a29} (Nightly Tester Tools, https://addons.mozilla.org/addon/6543)
     10% (6/60) vs.   1% (7/1085) {578e7caa-210f-4967-a0d3-88fe5b59a39f} (Textarea Cache, https://addons.mozilla.org/addon/5761)
      8% (5/60) vs.   0% (5/1085) nl-NL@dictionaries.addons.mozilla.org (Woordenboek Nederlands, https://addons.mozilla.org/addon/3291)
      8% (5/60) vs.   0% (5/1085) {848DC626-5EC9-4D09-A19F-E7F708EE2475}
      8% (5/60) vs.   0% (5/1085) jid1-bpzDizt9E1R7nw@jetpack
      8% (5/60) vs.   0% (5/1085) {336f36f7-72b2-4314-984a-ae7cac4b7328} (Extended Cookie Manager, https://addons.mozilla.org/addon/1243)
      8% (5/60) vs.   1% (6/1085) SQLiteManager@mrinalkant.blogspot.com (SQLite Manager, https://addons.mozilla.org/addon/5817)
      8% (5/60) vs.   1% (7/1085) color_management@seanhayes.name (Color Management, https://addons.mozilla.org/addon/6891)
      8% (5/60) vs.   1% (7/1085) {f36c6cd1-da73-491d-b290-8fc9115bfa55} (WorldIP, https://addons.mozilla.org/addon/8661)
      8% (5/60) vs.   1% (10/1085) {E6C1199F-E687-42da-8C24-E7770CC3AE66} (QuickJava, https://addons.mozilla.org/addon/1237)
      8% (5/60) vs.   1% (16/1085) {bb6bc1bb-f824-4702-90cd-35e2fb24f25d}
      8% (5/60) vs.   1% (16/1085) requestpolicy@requestpolicy.com (RequestPolicy, https://addons.mozilla.org/addon/9727)
     10% (6/60) vs.   3% (35/1085) {1BC9BA34-1EED-42ca-A505-6D2F1A935BBB}
      8% (5/60) vs.   2% (18/1085) jid1-F9UJ2thwoAm5gQ@jetpack
      8% (5/60) vs.   2% (19/1085) de-DE@dictionaries.addons.mozilla.org (German Dictionary, https://addons.mozilla.org/addon/3077)
     10% (6/60) vs.   5% (50/1085) firebug@software.joehewitt.com (Firebug, https://addons.mozilla.org/addon/1843)

MOZ_Crash|EXCEPTION_ACCESS_VIOLATION_WRITE (60 crashes)
     35% (21/60) vs.   8% (92/1085) msv1_0.dll
     65% (39/60) vs.  41% (444/1085) t2embed.dll
     45% (27/60) vs.  22% (234/1085) lz32.dll
     45% (27/60) vs.  22% (235/1085) wldap32.dll
     45% (27/60) vs.  22% (240/1085) xpsp2res.dll
     38% (23/60) vs.  16% (178/1085) MSCTFIME.IME
     82% (49/60) vs.  60% (650/1085) mozjs.dll
     48% (29/60) vs.  27% (296/1085) netapi32.dll
     45% (27/60) vs.  25% (274/1085) comres.dll
     55% (33/60) vs.  35% (383/1085) mpr.dll
     45% (27/60) vs.  25% (275/1085) hnetcfg.dll
     45% (27/60) vs.  25% (275/1085) wshtcpip.dll
     98% (59/60) vs.  80% (870/1085) nssckbi.dll
     22% (13/60) vs.   4% (40/1085) faultrep.dll
     45% (27/60) vs.  27% (294/1085) ws2help.dll
     50% (30/60) vs.  32% (349/1085) imagehlp.dll
     45% (27/60) vs.  27% (295/1085) iphlpapi.dll
     98% (59/60) vs.  81% (875/1085) freebl3.dll
     98% (59/60) vs.  81% (875/1085) nssdbm3.dll
    100% (60/60) vs.  83% (900/1085) winrnr.dll
     50% (30/60) vs.  33% (360/1085) winspool.drv
    100% (60/60) vs.  84% (911/1085) feclient.dll
     95% (57/60) vs.  80% (863/1085) psapi.dll
    100% (60/60) vs.  85% (923/1085) gkmedias.dll
    100% (60/60) vs.  86% (933/1085) browsercomps.dll
    100% (60/60) vs.  86% (937/1085) softokn3.dll
    100% (60/60) vs.  86% (938/1085) firefox.exe
    100% (60/60) vs.  87% (939/1085) xpcom.dll
     17% (10/60) vs.   3% (35/1085) captlib.dll
    100% (60/60) vs.  87% (940/1085) dbghelp.dll
     17% (10/60) vs.   3% (36/1085) mslbui.dll
     97% (58/60) vs.  84% (911/1085) lpk.dll
     27% (16/60) vs.  14% (155/1085) wtsapi32.dll
     25% (15/60) vs.  14% (154/1085) MSCTF.dll
    100% (60/60) vs.  89% (969/1085) dnsapi.dll
     12% (7/60) vs.   2% (22/1085) kloehk.dll
     27% (16/60) vs.  17% (185/1085) cryptui.dll
     27% (16/60) vs.  18% (192/1085) winsta.dll
    100% (60/60) vs.  91% (989/1085) wintrust.dll
     13% (8/60) vs.   5% (54/1085) atiuxpag.dll
     13% (8/60) vs.   5% (55/1085) atidxx32.dll
     13% (8/60) vs.   5% (58/1085) aticfx32.dll
    100% (60/60) vs.  93% (1007/1085) mswsock.dll
      8% (5/60) vs.   1% (14/1085) PrxerNsp.dll
      8% (5/60) vs.   1% (14/1085) PrxerDrv.dll
     55% (33/60) vs.  49% (529/1085) secur32.dll
     17% (10/60) vs.  11% (117/1085) msvcp60.dll
It's currently #1 top crasher in 14.0a1 over the last 3 days.
Duplicate of this bug: 739720
(In reply to Bobby Holley (:bholley) from comment #2)
> This stack doesn't seem to make sense - it certainly appears that it's on
> the main thread, and the crashing code is asserting just that...

Well, this still remains the #1 issue on trunk, so we better get some idea about it - at least how we can investigate further.
Depends on: 741056
correct me if I'm wrong (scoobidiver?), but crash-stats shows tihs disappearing from the nightlies starting with Apr 06.. 

https://crash-stats.mozilla.com/report/list?product=Firefox&version=Firefox%3A14.0a1&query_search=signature&query_type=contains&reason_type=contains&date=04%2F11%2F2012%2019%3A48%3A59&range_value=2&range_unit=weeks&hang_type=any&process_type=any&do_query=1&signature=nsXPConnect%3A%3APush%28JSContext*%29

That means almost certainly that its a dup of 741056 - which caused other weird corruptions too such as 740319 (and 741056 was a fix of an issue introduced in the regression range for this bug.)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 741056
You need to log in before you can comment on or make changes to this bug.