Port wifi and netutils code to ICS interfaces

RESOLVED FIXED

Status

()

Core
DOM: Device Interfaces
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: cjones, Assigned: cjones)

Tracking

Trunk
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Helpfully, the libnetutils interface changed in ICS.  Also, the wpa_supplicant states changed in a non-backwards compatible way.  We need to handle these changes.

philikon, I see that the RIL code has its own import of netutils.  We'll need the netutils fixes there.  Or better, let's share a netutils.  Maybe your network manager patch does that.
Created attachment 609186 [details] [diff] [review]
Add runtime checks for ICS and select libnetutils interface and wpa_supplicant states appropriately

There's some duplicated code in here, but I don't know how to share it without even worse hackery.

This stuff needs to be refactored along with RIL.
Assignee: nobody → jones.chris.g
Attachment #609186 - Flags: review?(gal)
Attachment #609186 - Flags: review?(mrbkap)

Comment 2

6 years ago
Comment on attachment 609186 [details] [diff] [review]
Add runtime checks for ICS and select libnetutils interface and wpa_supplicant states appropriately

Review of attachment 609186 [details] [diff] [review]:
-----------------------------------------------------------------

Land it. -15 karma for duplicating that code there. I am sure Blake will clean it up for you.
Attachment #609186 - Flags: review?(gal) → review+
https://hg.mozilla.org/mozilla-central/rev/7f87b434f7c6
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 737704
Depends on: 739335
(In reply to Chris Jones [:cjones] [:warhammer] from comment #0)
> philikon, I see that the RIL code has its own import of netutils.  We'll
> need the netutils fixes there.  Or better, let's share a netutils.  Maybe
> your network manager patch does that.

Correct. See bug 738063 which I didn't get to land before I went away for a few days last week. I'll rebase.

Updated

6 years ago
Attachment #609186 - Flags: review?(mrbkap)
You need to log in before you can comment on or make changes to this bug.