crash in nsHttpConnectionMgr::PostEvent

RESOLVED DUPLICATE of bug 741056

Status

()

Core
Networking: HTTP
--
critical
RESOLVED DUPLICATE of bug 741056
6 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Assigned: mcmanus)

Tracking

({crash, regression})

14 Branch
x86
Windows XP
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
It first appeared in 14.0a1/20120325.
The regression range might be (low volume):
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=df1f94b2bdee&tochange=20a01901480f

Signature 	nsHttpConnectionMgr::PostEvent(void ( nsHttpConnectionMgr::*)(int, void*), int, void*) More Reports Search
UUID	c69ba764-418c-419f-9123-7a5a62120326
Date Processed	2012-03-26 05:38:28
Uptime	1918
Last Crash	32.3 minutes before submission
Install Age	43.9 minutes since version was first installed.
Install Time	2012-03-26 04:50:24
Product	Firefox
Version	14.0a1
Build ID	20120325031055
Release Channel	nightly
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 37 stepping 5
Crash Reason	EXCEPTION_ACCESS_VIOLATION_EXEC
Crash Address	0x65747369
App Notes 	
AdapterVendorID: 0x10de, AdapterDeviceID: 0x0a2c, AdapterSubsysID: 1521103c, AdapterDriverVersion: 6.14.12.6128
D3D10 Layers? D3D10 Layers- D3D9 Layers? D3D9 Layers+ 
EMCheckCompatibility	True	
Total Virtual Memory	2147352576
Available Virtual Memory	1787899904
System Memory Use Percentage	33
Available Page File	4367712256
Available Physical Memory	2135650304

Frame 	Module 	Signature [Expand] 	Source
0 		@0x65747369 	
1 	xul.dll 	nsHttpConnectionMgr::PostEvent 	netwerk/protocol/http/nsHttpConnectionMgr.cpp:205
2 	xul.dll 	nsHttpConnectionMgr::CancelTransaction 	netwerk/protocol/http/nsHttpConnectionMgr.cpp:319
3 	xul.dll 	nsHttpChannel::Cancel 	netwerk/protocol/http/nsHttpChannel.cpp:3804
4 	xul.dll 	nsHttpChannel::ProcessFailedSSLConnect 	netwerk/protocol/http/nsHttpChannel.cpp:883
5 	xul.dll 	nsHttpChannel::ProcessResponse 	netwerk/protocol/http/nsHttpChannel.cpp:997
6 	xul.dll 	nsHttpChannel::OnStartRequest 	netwerk/protocol/http/nsHttpChannel.cpp:4316
7 	xul.dll 	nsInputStreamPump::OnStateStart 	netwerk/base/src/nsInputStreamPump.cpp:444
8 	xul.dll 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:399
9 	xul.dll 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:114
10 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:656
11 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
12 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:201
13 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:175
14 	xul.dll 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:189
15 	xul.dll 	nsAppShell::Run 	widget/windows/nsAppShell.cpp:267
16 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:295
17 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3703
...

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsHttpConnectionMgr%3A%3APostEvent%28void+%28+nsHttpConnectionMgr%3A%3A*%29%28int%2C+void*%29%2C+int%2C+void*%29

Comment 1

6 years ago
Patrick - is this a regression from your pipelining patches?
Assignee: nobody → mcmanus
Blocks: 739762
(Assignee)

Updated

6 years ago
Depends on: 741056
(Assignee)

Comment 2

6 years ago
see stack of comment 15 in 741056 - dup.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
No longer depends on: 741056
Resolution: --- → DUPLICATE
Duplicate of bug: 741056
You need to log in before you can comment on or make changes to this bug.