The default bug view has changed. See this FAQ.

"Fx10+ Conditionally Hidden Forward Button" Fx feature disabled by CSS element Id=fullscreenflex

RESOLVED FIXED

Status

()

Firefox
Toolbars and Customization
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rob64rock, Unassigned)

Tracking

12 Branch
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed by bug 739093, URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20120325 Firefox/14.0a1
Build ID: 20120325031055

Steps to reproduce:

Ya'll know how there has been a quite of few reports from users on (forums.mozillazine.org) that the Fx feature "Fx10+ Conditionally Hidden Forward Button" in Large Icon mode isn't working, and we all say "Make sure nothing is between your Forward/Back buttons and the Urlbar" and when they say "There isn't nothing there" we say "Reset your toolbars back to there default set in 'Customize Toolbar Palette' ".

I had do that my self a more than a few times since I'm testing Fx Beta, Aurora and Nightly builds. Today I got tired of having to reset my toolbars to get it to work. I used DOM Inspector to investigate and to my surprise there was hidden nav-bar toolbar element under the (CSS Id=fullscreenflex) that you can't move by 'drag and drop' using the 'Customize Toolbar Palette' since it invisible.


So, I made this CSS code.



#navigator-toolbox[iconsize=large][mode=icons][customizing="true"] > #nav-bar #fullscreenflex {
display: -moz-box !important;
background-color: yellow !important;
min-width: 30px !important; }



So, I could see it when using the 'Customize Toolbar Palette' in Large Icon Mode to be able to move my other Nav-bar toolbar elements(buttons) to either side of it, so I could restore the function of the Fx feature "Fx10+ Conditionally Hidden Forward Button".

Is it intentional for it be able move around unchecked like it does?



Expected results:

The CSS element Id=fullscreenflex shouldn't be able to move from it's default position to prevent disabling the Fx feature "Fx10+ Conditionally Hidden Forward Button".
(Reporter)

Updated

5 years ago
Component: Untriaged → Toolbars
Depends on: 739093

Updated

5 years ago
QA Contact: untriaged → toolbars
(Reporter)

Updated

5 years ago

Updated

5 years ago
Duplicate of this bug: 734619

Updated

5 years ago
Blocks: 682534
(Reporter)

Comment 2

5 years ago
This problem is fixed in the latest Fx 14.0a1 due to Bug 739093 , but I'm waiting to get a response here: https://bugzilla.mozilla.org/show_bug.cgi?id=739093#c11 , before changing Bug 739160 Status.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: fixed by bug 739093
You need to log in before you can comment on or make changes to this bug.