If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Search button resolves search text containing a '.' and a space as a URL

VERIFIED DUPLICATE of bug 73974

Status

SeaMonkey
Search
VERIFIED DUPLICATE of bug 73974
17 years ago
9 years ago

People

(Reporter: emmet, Assigned: matt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.8.1) Gecko/20010323
BuildID:    2001032319

If you enter the text (eg) "mozilla 0.81" and click on
the 'search' button to its right then Mozilla interprets
this text as a URL and then (doh) can't find it. The full
stop seems to be the determing factor.

Without getting involved in the usability debate, surely
if there is a space in the address box then the text should
not be interpreted as a URL but as a search term (for what URL
contains a space?).

Reproducible: Always
Steps to Reproduce:
1.Type "emmet spier." in the address box
2.Click 'Search'
3.hmm

Comment 1

17 years ago
Confirming on linux 2001032821

Type mozilla.org and click on search
Result: Mozilla page is loaded
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Comment 2

17 years ago
Same thing happens if you try to search for "something http:// something else"

Comment 3

17 years ago
*** Bug 74994 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
Gilles,
> Type mozilla.org and click on search
> Result: Mozilla page is loaded

This is intentional, it was changed a while back that if you entered a URL or
something resembling a URL it'd act as a Go button rather than a search button.
I can't remember the bug number for this tho.

This bug is for search terms containing a dot and a space (and therefore can't
be a URL)

Comment 5

17 years ago
It is understood that we need a better algorithm for determining what is/isn't a url, fine.
let's get this fix since it's an easy win if we can add this case.
Keywords: nsbeta1
Summary: Search button resolves search text containing a '.' as a URL → Search button resolves search text containing a '.' and a space as a URL

Comment 6

17 years ago
hot damn, dunno how I missed the dupe. The other bug has the appropriate audience
and bells and whistle - so marking this as the dupe.


*** This bug has been marked as a duplicate of 73974 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
double-checked and definitely a dupe.
VERIFIED Dupe
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.