.eml files opened from Mac Finder don't open if thunderbird isn't running

RESOLVED DUPLICATE of bug 243543

Status

Thunderbird
OS Integration
RESOLVED DUPLICATE of bug 243543
6 years ago
6 years ago

People

(Reporter: Stuart A. Malone, Unassigned)

Tracking

11 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/534.54.16 (KHTML, like Gecko) Version/5.1.4 Safari/534.54.16

Steps to reproduce:

- Save a message as a .eml file to the desktop.
- Quit Thunderbird.
- Double-click on the .eml file in the Finder.


Actual results:

- Thunderbird launched, but the .eml file did not open.


Expected results:

- Thunderbird should launch and the .eml file should appear in a window (just as it does when Thunderbird is running).
(Reporter)

Comment 1

6 years ago
I should also mention that I have the Finder configured to open .eml files in Thunderbird by default. To reproduce the bug you have to make sure that .eml files open in Thunderbird rather than Apple Mail.

Updated

6 years ago
Summary: .eml files opened from Mac Finder don't open on launch → .eml files opened from Mac Finder don't open if thunderbird isn't running
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 726969
So yes we need apple events
Duplicate of bug: 243543
You need to log in before you can comment on or make changes to this bug.