Closed Bug 739358 Opened 8 years ago Closed 8 years ago

HTML5 Fullscreen API broken with new Lion Full Screen support

Categories

(Firefox :: Untriaged, defect)

14 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 726943

People

(Reporter: tschopp, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20120326 Firefox/14.0a1
Build ID: 20120326031149

Steps to reproduce:

1) Go to http://html5-demos.appspot.com/static/fullscreen.html


Actual results:

2) Click one of the 'toggle fullscreen' buttons
3) Firefox window goes into fullscreen mode (Lion style) but the content is not fullscreen at all.
4) Click the button a couple times more to actually trigger the desired fullscreen effect


Expected results:

Step 4) should happen after a single click.
This is a regression since the native Lion fullscreen support replaced the old Fullscreen (pre-Lion) implementation.
Thanks for taking time to report this issue! It's already reported though, and the patch in bug 726943 fixes the page you linked to.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 726943
You need to log in before you can comment on or make changes to this bug.