Closed Bug 739378 Opened 11 years ago Closed 11 years ago

[Firefox Flicks] Design Contest Closed Homepage

Categories

(Marketing :: Design, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ckoehler, Assigned: tshahian)

References

()

Details

(Whiteboard: Due: 4/18)

Attachments

(8 files, 3 obsolete files)

We'll need a version of the Firefox Homepage to run after the contest has closed but before winners are announced.

The deadline for this will depend on how much new copy there is to be localized. Ideally we should be done by 4/18 for the 5/1 release.

cc'ing Jinghua so she can advise on UX.
Thanks, ccing Lee and Matej.  Though I'm not clear on what the content direction is and whether there are wireframes we're referencing or not.  More information / clarification would be helpful.
There's a two and a half week gap between the close of the contest and the announcement of winners. The current homepage design is entirely geared towards promoting submissions, which won't make sense after the contest is closed. 

Chelsea should be able to jump in and explain what should be promoted on the homepage while submissions are being judged.

We don't have wireframes for this iteration, which is why I've cc'd Jinghua.
I'm also open to suggestions about what we should feature. Clearly we need to convey that the contest is closed, but we also want to encourage people to watch the videos and generate excitement about the announcement on or about the 17th of May. 

Should we have a call to talk it through?
Christie, is it a Q2 goal for you? I will talk with Bryan, Bram's manager, to see if he can get squeeze some time for you.

Chelsea, if you plan to schedule a call, please invite Bryan Clark.
Can we use the recent videos page and add some copy at the top that says the contest is closed, judging will be announced at x date, etc? In that case, all we need is to write some copy, format it at the top, and switch it over to being the home page.

https://firefoxflicks.mozilla.org/en-US/recent
Please welcome Lee to the design stage !!  wohoo. 
Please invite Lee to the related calls surrounding wireframes/design.
Status: NEW → ASSIGNED
(In reply to Jinghua zhang from comment #4)
> Christie, is it a Q2 goal for you? I will talk with Bryan, Bram's manager,
> to see if he can get squeeze some time for you.

Yes it is a Q2 goal. The contest is already live and has a fixed dates for the contest close and announcement of winners.
Whiteboard: Due: 4/18
Attached image Contest closed with red curtain (obsolete) —
We can also extend the red curtain (note that this mockup has rough edges) to give more weight to the message.
Matej, could you write up some copy for this page. What we want to convey is that 

1) The contest is closed
2) Winners will be announced on May 17
3) People should still view and share flicks entries while they wait

Let me know if you have any questions on this. 

If you could do this in the next few days, it would help Bram and Lee in terms of making sure the design fits the copy we use. 

Thanks :)
Here you go. Let me know what you think and if it fits the page.


That's a wrap!

Thanks to everyone for the awesome flicks. Our judges are now sequestered (with plenty of popcorn) to choose the winners, but you can still watch the entries and share your favorites while you wait for the big announcement on May 17.
+1 from me. Kristin, is there anything we're missing?
Blocks: 745222
Like the copy, lets go with it. I'd like to see the layout as soon as we have it. Thanks.
Attached image Contest closed with red curtain (obsolete) —
The background curtain is now fade to black, which should be easier to implement and scale to small sizes.
Attachment #612882 - Attachment is obsolete: true
Attached image Contest closed with red curtain (obsolete) —
Updated with a longer image that shows the fade to black effect in full.
Attachment #616279 - Attachment is obsolete: true
Attached image Orange text
Attachment #616282 - Attachment is obsolete: true
Attached image White text
I like the orange text one. Kristin, can you have a look and let us know. This is for the contest landing page between May 1 and May 17.
I like the orange text as well. I shared these and here are a few quick thoughts from Pete and myself: 

3 quick things.  

Since this is still the main page for the contest, lets include the trailers above the submitted content. (our trailers)  They're still the best content we've received.  

I'd put the drop down menus against a black background (like the film thumbnails) so that the controls are tied to the content.  

If it can be done well, I'd find a way to put a "Download Firefox" bug somewhere under the main paragraph.
Just a note that the highlights will cause an l10n change and will have to be confirmed before tomorrow morning's string freeze. Also, if adding the trailers needs new strings, we'll need that before tomorrow as well.
I don't believe adding the trailers creates new strings, since they're already on the current homepage. Please use the descriptions that are currently there. 

I believe the only additional string would be the "Download Firefox"

Cheers, 
C
Put in the background layer
Mkelly - did you add the 'download firefox' for the merge?
I did. Download Firefox made it in. Per IRC discussion, we're going with the orange text, and then this page should be finished.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
Is there a revised mock up with this page that includes the download firefox button?
You can see it here: 
http://firefoxflicks-dev.allizom.org/en-US/

I thought the button was going to be at the top.
Sorry if this was already discussed and I missed it, but is there a reason we're not using the download button with the logo on it, like this one:

http://cl.ly/1Z2k37452l3M2g3w3x0Z

If not, I think that's what we should be using.
Mostly because that's a link made to look like a button. In order to meet the deadlines we have a the l10n cycle, we couldn't go with the typical button. 

Jen, Mike, is that explanation basically right? Jet lag is making things a bit of a blur.
My concern is that doing something that doesn't follow our brand guidelines looks unofficial and therefore could look like a mistake. John, Lee, what do you guys think?

I also wonder if there's some way to make the trailers stand apart from the other videos so it's clear they're not entries to people visiting this site for the first time (maybe that's the plan anyway, I just don't see them at the top of the current page).
It would certainly be nice if the button could look a little more Firefoxy. Almost more than the lack of a logo, it just seems a little oddly placed right there at the bottom. Not sure if there are any options at this point...not a crisis if it has to stay where it is, but it does feel a bit unfinished.
Attached image Button in top bar
Perhaps adding a logo and putting the button in the top bar? Here's a mockup (positioning and sizing isn't quite right, and the edge of the green button is visible at the side, but bear with me here) with something that might work. 

Bonus here is that the download button appears on every page.
Comment on attachment 617910 [details]
Button in top bar

That looks great to me. Matej, John, does that help with your button concerns?
Yes, that looks much better to me. Thanks.

John, should we keep the Georgia there or should that be Open Sans?
Georgia is fine - thanks!
Does this look good?

I talked with Chelsea and we decided that the button would not be visible in mobile layouts, since it currently links to "https://www.mozilla.org/firefox/new" which only covers the desktop version of Firefox, and the logic for detecting the device is out-of-scope (and I'll be gone on PTO before I can finish it :x).
Comment on attachment 618029 [details]
Final design for logged in view.

Looks great Mike. Thank you.
Looks good. Thanks!
Love it, thanks!
You need to log in before you can comment on or make changes to this bug.