Last Comment Bug 739421 - Implement ARB_sync in GLContext
: Implement ARB_sync in GLContext
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla14
Assigned To: Jeff Gilbert [:jgilbert]
:
Mentors:
http://www.opengl.org/registry/specs/...
Depends on:
Blocks: 555834 697831 716859 721115
  Show dependency treegraph
 
Reported: 2012-03-26 14:46 PDT by Jeff Gilbert [:jgilbert]
Modified: 2012-04-18 00:40 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Implement/expose ARB_sync to GLContext (7.55 KB, patch)
2012-03-26 16:19 PDT, Jeff Gilbert [:jgilbert]
jacob.benoit.1: review+
Details | Diff | Splinter Review
Implement/expose ARB_sync to GLContext (9.38 KB, patch)
2012-03-30 16:58 PDT, Jeff Gilbert [:jgilbert]
no flags Details | Diff | Splinter Review
Implement/expose ARB_sync to GLContext (9.37 KB, patch)
2012-03-30 17:13 PDT, Jeff Gilbert [:jgilbert]
no flags Details | Diff | Splinter Review
Implement/expose ARB_sync to GLContext (10.00 KB, patch)
2012-04-05 15:16 PDT, Jeff Gilbert [:jgilbert]
no flags Details | Diff | Splinter Review
Implement/expose ARB_sync to GLContext (10.32 KB, patch)
2012-04-05 16:26 PDT, Jeff Gilbert [:jgilbert]
jacob.benoit.1: review+
Details | Diff | Splinter Review

Description Jeff Gilbert [:jgilbert] 2012-03-26 14:46:21 PDT
There are a couple different bugs around which need ARB_sync. We should throw it into GLContext here, since it's easy to simply implement and expose it. At least we can get ARB_sync into GLContext quickly, and get the individual uses in as they become ready.
Comment 1 Jeff Gilbert [:jgilbert] 2012-03-26 16:19:44 PDT
Created attachment 609525 [details] [diff] [review]
Implement/expose ARB_sync to GLContext
Comment 2 Jeff Gilbert [:jgilbert] 2012-03-26 16:23:14 PDT
This patch exposes FenceSync, DeleteSync, WaitSync, and GetSynciv as per spec. Other functions are part of the spec as well, but these are the functions that are most useful to us, and that I have seen used by other patches.
Comment 3 Jeff Gilbert [:jgilbert] 2012-03-28 16:55:29 PDT
Waiting on Try build:
https://tbpl.mozilla.org/?tree=Try&rev=9194ec4fb9f4
Comment 4 Jeff Gilbert [:jgilbert] 2012-03-30 16:58:19 PDT
Created attachment 611088 [details] [diff] [review]
Implement/expose ARB_sync to GLContext

Same patch in principle, but exposes all functionality of ARB_sync, instead of what I had arbitrarily (and incorrectly) thought would be all we would need.

Try-build at:
https://tbpl.mozilla.org/?tree=Try&rev=526c6332ba2a
Comment 5 Jeff Gilbert [:jgilbert] 2012-03-30 17:13:16 PDT
Created attachment 611094 [details] [diff] [review]
Implement/expose ARB_sync to GLContext
Comment 6 Jeff Gilbert [:jgilbert] 2012-03-30 17:14:13 PDT
Try-build:
https://tbpl.mozilla.org/?tree=Try&rev=2d41ddc2e40a
Comment 7 Jeff Gilbert [:jgilbert] 2012-04-05 15:16:23 PDT
Created attachment 612703 [details] [diff] [review]
Implement/expose ARB_sync to GLContext

Finally got it building on android by using "mozilla/StandardInteger.h".
Comment 8 Jeff Gilbert [:jgilbert] 2012-04-05 16:26:05 PDT
Created attachment 612737 [details] [diff] [review]
Implement/expose ARB_sync to GLContext

Bitrot from bug 741689.
Comment 10 Matt Brubeck (:mbrubeck) 2012-04-09 10:13:01 PDT
https://hg.mozilla.org/mozilla-central/rev/a29bc0e8de0a

Note You need to log in before you can comment on or make changes to this bug.