Possible mac problem in form manager preview screen

VERIFIED FIXED

Status

()

Toolkit
Form Manager
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Stephen P. Morse, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I recently made changes to the form manager preview screen which involved the 
creation of a new file named extensions/wallet/walletpreview/WalletPreview.dtd.  
However that file was never added to the MANIFEST_PROPERTIES file in that 
directory.

I believe that this will cause the form-manager preview screen (the screen that 
pops up when you attempt to prefill a form) to have its text missing.  tpreston, 
can you please confirm that this is what is happening on the mac.

If so, the fix is simply to change MANIFEST_PROPERTIES from its current one-line

   WalletPreview.properties

to the two lines

   WalletPreview.properties
   WalletPreview.dtd
(Reporter)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9

Comment 1

17 years ago
Yeah morse, this screen is hosed.  There is one line at the top of the dialog 
that says check the items that you would like to have prefilled with a button to 
view stored form data (that works) and then at the bottom of the dialog is a 
line with bypass this screen when prefilling in the future, than OK and cancel 
buttons.  No prefill data

Comment 2

17 years ago
Unless there's something that I don't know about (very possible), I'm not sure 
MANIFEST_PROPERTIES files are used by the mac build.
(Reporter)

Comment 3

17 years ago
Oops, Paul, you are right.  This mechanism has long since been obsoleted.

So now I can't explain the problem that Terri is seeing.  In fact, had it been 
the lack of the .dtd file in the manifest, she wouldn't see any of the strings 
at all (she reports she is seeing the string on the top and bottom but the 
middle is missing.

Terri, do you have saved data for the form you are prefilling?  (Although if you 
didn't, you shouldn't be able to even bring up this dialog.)  Also, can you 
reproduce this on other platforms?

Comment 4

17 years ago
Hey morse, I actually can't reproduce on todays build?  But I re-installed on 
mac build 2001032908 and could see this behavior (Have not seen on other 
platforms)  Also, I notice that the dialog that usually say data has been 
captured, has no text?
(Reporter)

Comment 5

17 years ago
Now that's a new problem (lack of text in "data has been captured" 
notification).  Is this happening only on the mac or is it cross-platform?  And 
is it still happening?
(Reporter)

Comment 6

17 years ago
Terri, please reply to my questions above.  Thanks.

Comment 7

17 years ago
sorry morse, I have been working on tons of imagelib bugs, but both of these
behaviors are working correctly on the mac (as of 2001040309), "data has been
captured" is in the dialog and the preview screen shows prefill data.  Closing
as fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
Verified fixed mac build 2001051705
Verified fixed w98 build 2001051704
Verified fixed linux build 2001051706
Status: RESOLVED → VERIFIED

Updated

10 years ago
Assignee: morse → nobody
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: tpreston → form.manager
Target Milestone: mozilla0.9 → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.