Last Comment Bug 739537 - Leading spaces in selection not exported to clipboard upon copy
: Leading spaces in selection not exported to clipboard upon copy
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Serializers (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
:
:
Mentors:
: 762961 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 00:31 PDT by Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
Modified: 2012-06-08 14:15 PDT (History)
3 users (show)
hsivonen: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Get rid of the quirk (4.20 KB, patch)
2012-03-27 01:11 PDT, Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
bugs: review+
Details | Diff | Splinter Review

Description Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2012-03-27 00:31:08 PDT
Steps to reproduce:
 1) On any Web page, locate a word that has spaces before and after.
 2) Select the space before, the word and the space after.
 3) Press ctrl-c (cmd-c on Mac)
 4) Switch to a plain text editor app (e.g. gedit on Linux; don't switch to a word processor that support styling)
 5) Type two letters (e.g. "AB") in the text editor.
 6) Move the caret between the two letters.
 7) Press ctrl-v (cmd-v on Mac)

Actual results:
The word and the trailing space are pasted. The leading space is not pasted.

Expected results:
Expected all the text in the original selection--including the leading space--to be pasted.
Comment 1 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2012-03-27 01:11:07 PDT
Created attachment 609649 [details] [diff] [review]
Get rid of the quirk
Comment 2 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2012-03-27 02:05:32 PDT
Note that bug 564737 was about mailnews message conversions and the effect on clipboard export was just collateral damage. The duplicates of bug 564737 are about mailnews message conversion, too.
Comment 3 Olli Pettay [:smaug] 2012-03-30 11:13:47 PDT
Comment on attachment 609649 [details] [diff] [review]
Get rid of the quirk

Ok, let's try this then.
Comment 4 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2012-04-02 23:47:34 PDT
Thanks.
https://hg.mozilla.org/integration/mozilla-inbound/rev/7857c5bff017
Comment 5 Matt Brubeck (:mbrubeck) 2012-04-03 10:56:36 PDT
https://hg.mozilla.org/mozilla-central/rev/7857c5bff017
Comment 6 Jason Smith [:jsmith] 2012-06-08 14:15:38 PDT
*** Bug 762961 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.