The default bug view has changed. See this FAQ.

forwarding message puts cursor at end instead of beginning

RESOLVED FIXED in Thunderbird 15.0

Status

Thunderbird
Message Compose Window
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: Jonathan Kamens, Assigned: mconley)

Tracking

({qawanted, regression})

Trunk
Thunderbird 15.0
qawanted, regression

Thunderbird Tracking Flags

(thunderbird13+ fixed, thunderbird14+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
With nightly just updated from HG, if you forward a message inline the cursor starts at the end of the text in the forward compose window.

With TB 11 it is positioned at the beginning, above the forward, as it's supposed to be.
(Reporter)

Updated

5 years ago
Summary: forwarding message puts cursor at beginning instead of end → forwarding message puts cursor at end instead of beginning
(Reporter)

Comment 1

5 years ago
This bug is now in the Thunderbird 13 beta. It's a regression. Surely it needs to be fixed before it gets shipped? Is somebody looking at it?
tracking-thunderbird13: --- → ?
Keywords: qawanted
Joe, do you have a version 11 or 12 to compare?

It does start at the end with current nightly.

Comment 3

5 years ago
I have an oldish V11 handy here:
Mozilla/5.0 (Windows NT 5.1; rv:11.0a1) Gecko/20111125 Thunderbird/11.0a1
Works as expected on tabbing into the body.
Cursor at the top.
My guess is this is a Editor core change though.
I can test further this evening.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → mconley
Created attachment 620304 [details] [diff] [review]
Patch v1

This regression got introduced when Filelink landed, because we wanted to wrap inline forwards in a DIV to make inserting URLs sane.  It looks like our logic for setting the selection was out of order.

This patch fixes that, and I've added a regression test.
Attachment #620304 - Flags: review?(dbienvenu)
(This bug affects TB 13+)
status-thunderbird13: --- → affected
status-thunderbird14: --- → affected
tracking-thunderbird14: --- → ?
OS: Linux → All

Comment 6

5 years ago
Forward wants to end up with the cursor in the To: field, doesn't it, so this bug is really about where the cursor will go after you tab out of the To: field. In any case, this does fix it, thx!

Comment 7

5 years ago
Comment on attachment 620304 [details] [diff] [review]
Patch v1

[Triage Comment]
Attachment #620304 - Flags: review?(dbienvenu)
Attachment #620304 - Flags: review+
Attachment #620304 - Flags: approval-comm-beta+
Attachment #620304 - Flags: approval-comm-aurora+
comm-central: http://hg.mozilla.org/comm-central/rev/471262b51178
comm-aurora: http://hg.mozilla.org/releases/comm-aurora/rev/853e0b823a97
comm-beta: http://hg.mozilla.org/releases/comm-beta/rev/ba9ff38469ba
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-thunderbird13: affected → fixed
status-thunderbird14: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 15.0

Updated

5 years ago
Hardware: x86_64 → All
tracking-thunderbird13: ? → +
tracking-thunderbird14: ? → +
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.