Closed Bug 739640 Opened 10 years ago Closed 9 years ago

Fennec crash in JSC::ExecutableAllocator::sizeOfCode

Categories

(Core :: JavaScript Engine, defect)

14 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 710922
Tracking Status
blocking-fennec1.0 --- soft

People

(Reporter: scoobidiver, Unassigned)

Details

(Keywords: crash, regression, topcrash, Whiteboard: [js:inv:p1][native-crash][mobile-crash])

Crash Data

It's the mobile version of bug 710922.

Signature 	JSC::ExecutableAllocator::sizeOfCode More Reports Search
UUID	5c5d87aa-ec17-40ed-81fd-6fb572120322
Date Processed	2012-03-22 04:10:28
Uptime	61
Last Crash	1.5 hours before submission
Install Age	39.8 minutes since version was first installed.
Install Time	2012-03-22 03:30:29
Product	FennecAndroid
Version	14.0a1
Build ID	20120321031151
Release Channel	nightly
OS	Linux
OS Version	0.0.0 Linux 2.6.39.4+ #1 SMP PREEMPT Wed Feb 8 19:45:47 CST 2012 armv7l
Build Architecture	arm
Build Architecture Info	
Crash Reason	SIGSEGV
Crash Address	0x0
App Notes 	
EGL? EGL+ AdapterVendorID: picasso_e, AdapterDeviceID: A200.
AdapterDescription: 'NVIDIA, Model: 'A200', Product: 'a200_emea_uk', Manufacturer: 'Acer', Hardware: 'picasso_e''.
GL Context? GL Context+ GL Layers? GL Layers+ 
Acer A200
acer/a200_emea_de/picasso_e:4.0.3/IML74K/1328547022:user/release-keys
EMCheckCompatibility	True

Frame 	Module 	Signature [Expand] 	Source
0 	libxul.so 	JSC::ExecutableAllocator::sizeOfCode 	HashTable.h:181
1 	libxul.so 	JSRuntime::sizeOfExcludingThis 	js/src/jscntxt.cpp:109
2 	libxul.so 	JS::GetExplicitNonHeapForRuntime 	js/src/MemoryMetrics.cpp:316
3 	libxul.so 	JSMemoryMultiReporter::GetExplicitNonHeap 	js/xpconnect/src/XPCJSRuntime.cpp:1882
4 	libxul.so 	nsMemoryReporterManager::GetExplicit 	xpcom/base/nsMemoryReporterManager.cpp:805
5 	libxul.so 	MemoryReporter_Explicit::GetAmount 	xpcom/base/nsMemoryReporterManager.cpp:58
6 	libxul.so 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp:194
7 	libxul.so 	XPCWrappedNative::CallMethod 	js/xpconnect/src/XPCWrappedNative.cpp:3021
8 	libxul.so 	XPC_WN_GetterSetter 	js/xpconnect/src/xpcprivate.h:2672
9 	libxul.so 	js::InvokeGetterOrSetter 	js/src/jscntxtinlines.h:314
10 	libxul.so 	js::GetPropertyHelper 	js/src/jsscopeinlines.h:287
11 	libxul.so 	js::Interpret 	js/src/jsinterpinlines.h:268
12 	libxul.so 	js::RunScript 	js/src/jsinterp.cpp:469
13 	libxul.so 	js::Invoke 	js/src/jsinterp.cpp:528
14 	libxul.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:5385
15 	libxul.so 	nsXPCWrappedJSClass::CallMethod 	js/xpconnect/src/XPCWrappedJSClass.cpp:1518
16 	libxul.so 	nsXPCWrappedJS::CallMethod 	js/xpconnect/src/XPCWrappedJS.cpp:617
17 	libxul.so 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp:138
...

More reports at:
https://crash-stats.mozilla.com/report/list?signature=JSC%3A%3AExecutableAllocator%3A%3AsizeOfCode
It's #11 top crasher in FennecAndroid 14.0b3.
blocking-fennec1.0: --- → ?
Keywords: topcrash
Version: 11 Branch → 14 Branch
#11 seems too low for now. Renom if things change.
blocking-fennec1.0: ? → -
(In reply to Joe Drew (:JOEDREW!) from comment #2)
> #11 seems too low for now. Renom if things change.
There are 6.5 crashes/100 ADU in FennecAndroid 14.0b3 and 2 crashes/100 ADU in Firefox 12.0. So if you want the same crash ratio, you must remove 70% of crashes. It's worth removing a crash signature that represents 1.5% of crashes in 14.0b3.
Nomming for soft blocking status.
blocking-fennec1.0: - → ?
blocking-fennec1.0: ? → soft
(In reply to Joe Drew (:JOEDREW!) from comment #2)
> #11 seems too low for now. Renom if things change.
It's now #8 top crasher (#7 without fixed ones) in 14.0b3.
Whiteboard: [native-crash][mobile-crash] → [js:inv:p1][native-crash][mobile-crash]
This is definitely a dup of bug 710922 -- for which I just put up a patch that fixes it -- but I'll let someone else mark this bug as such, because I'm not sure what the protocol is for Fennec right now.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 710922
You need to log in before you can comment on or make changes to this bug.