permissions for relops on phx esx cluster

RESOLVED FIXED

Status

Infrastructure & Operations
Virtualization
--
major
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: MaRu, Assigned: lerxst)

Tracking

Details

(Reporter)

Description

6 years ago
I am requesting an SCL3 admin account for the ESX cluster so I can start work on the Windows Forest.
(Reporter)

Updated

6 years ago
Severity: normal → major
(Assignee)

Comment 1

6 years ago
Please tell me which VLAN your VMs will be on so I can set up permissions appropriately.
Status: NEW → ASSIGNED
(Reporter)

Comment 2

6 years ago
Dan and I got this sorted out and the account is created.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

6 years ago
Dan I also needed access to the PHX cluster as well and at the moment cannot reach it.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: SCL3 ESX cluster admin user account → ESX cluster admin user account
(Assignee)

Comment 4

6 years ago
The ESX cluster in phx1 is almost 100% full. Until additional capacity is added, please continue to use scl3.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

6 years ago
Why didn't you bring this up to us before?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Dan: This is for the mozilla-wide windows AD domain.  We need to create hosts in both scl3 and phx for redundancy.  Eventually this will be 3 hosts, but right now we need one.  The vms will have the following specs:

1 cpu 
2gb ram 
60gb hdd

We won't be taxing the phx cluster greatly.  :}
(Assignee)

Comment 7

6 years ago
OK, access is set up. Please don't use more than 4GB RAM total in the VMs you create until we get additional capacity online. The other resource shortage in that cluster is disk IOPS.

I didn't bring this up when we met about your AD project because the problem didn't exist then. Since that meeting we've created about 30 VMs for Ateam that ate up a ton of resources.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

6 years ago
ohhh okay no problem I am only going to deploy the root DC for now which will only be 2gb RAM also this is the second DC so it won't have a whole lot of I/O going on so the disk IOPS shouldn't be effected to bad.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 9

6 years ago
I no longer have access to the releng folder and I cant get into the phx server which is prompting me with this error http://imgur.com/GwrMc
(Reporter)

Comment 10

6 years ago
Dan I have uninstalled and reinstalled the client twice now and still I am getting an error when only trying to connect to the phx esx host. This is blocking me on multiple bugs now for my account not being setup correctly.
(Assignee)

Comment 11

6 years ago
I can't find anything wrong with your account. To continue testing I'd like to reset your password to something else temporarily so I can try logging in as you from my computer. Is that alright with you?
(Reporter)

Comment 12

6 years ago
So I can connect via the vsphere client now (I am in the office today connected to Natasha) But yes if you need to do that go ahead.
(Assignee)

Comment 13

6 years ago
I have changed absolutely nothing with your account, so the fact that it is working now further solidifies my assessment that the problem is on your end, either with your Windows installation or vSphere Client installation. Normally I'd be happy to help troubleshoot end user client issues but I have too many other critical issues to handle.

If you are unable to log in again, please use a different Windows computer.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

6 years ago
I dont have access on phx1 to power on my VM nor does it give me a network adapter
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 15

6 years ago
Things seem to be working now I will close this and if need be open the bug in the future. Thanks again Dan.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Looks like we hit that regression bug again.  Permission granted in comment 14 have disappeared again.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: ESX cluster admin user account → permissions for relops on phx esx cluster
(Assignee)

Comment 17

6 years ago
This should be fixed now, please try again and let me know.
(Reporter)

Comment 18

6 years ago
Dan it's closer as in I can now pick network adapters but I only have vlan75 to pick from. Can you add the releng vlans and vlan69.
(Assignee)

Comment 19

6 years ago
Those VLANs don't exist in the phx1 ESX cluster. If you think they should exist, can you please give me the bug numbers where netops said they created them in phx1?
(Reporter)

Comment 20

6 years ago
Dan please check bug 746024 

Per Casey's final comment "I added 69 to the firewall, core/intermediate switches, and the trunk ports to the esx hosts, added an interface for natasha. that should be it for you to get this up."
(Assignee)

Comment 21

6 years ago
OK, I'll set it up now
(Assignee)

Comment 22

6 years ago
OK it should be set up now, pleas try again
(Reporter)

Comment 23

6 years ago
it's there now but I dont have rights to make the change I can however see it in the drop down so we are close.
(Assignee)

Comment 24

6 years ago
OK, please try now
(Reporter)

Comment 25

6 years ago
perfection its working now. Thanks Dan.
(Reporter)

Comment 26

6 years ago
closing this bug and will open a new one if issues arise.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.