Last Comment Bug 739677 - No way to access the "Add Contact" and "Join Chat" actions of the IM feature with the keyboard
: No way to access the "Add Contact" and "Join Chat" actions of the IM feature ...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Disability Access (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 15.0
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 09:56 PDT by Marco Zehe (:MarcoZ)
Modified: 2012-06-04 12:26 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (633 bytes, patch)
2012-05-30 06:10 PDT, Florian Quèze [:florian] [:flo] (PTO until August 29th)
bwinton: review+
bwinton: ui‑review-
Details | Diff | Splinter Review
Patch v2 (6.71 KB, patch)
2012-06-04 06:26 PDT, Florian Quèze [:florian] [:flo] (PTO until August 29th)
bwinton: review+
bwinton: ui‑review+
mzehe: feedback+
Details | Diff | Splinter Review

Description Marco Zehe (:MarcoZ) 2012-03-27 09:56:22 PDT
Not all buttons in the tool bars like the "Ad contact", "join chat" and "Accounts" buttons are keyboard accessible/tabable. Others like the status menu button, search field etc. are. All of the buttons should be reachable via the keyboard.
Comment 1 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-03-27 10:25:17 PDT
Any idea of what we need to do to make these buttons tab accessible?
Comment 2 Marco Zehe (:MarcoZ) 2012-03-27 21:48:02 PDT
Add the moz-user-focus style to them: https://developer.mozilla.org/en/CSS/-moz-user-focus
Comment 3 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-05-30 06:10:35 PDT
Created attachment 628320 [details] [diff] [review]
Patch

The attached patch fixes the issue described in comment 0 with the solution proposed in comment 2.

I'm wondering however:
- Should we do this for all toolbar buttons instead? (Is it the expected behavior that the toolbar buttons of the email tabs aren't focusable?)
- Do we need some theming changes? On Mac the focus is completely invisible on the toolbar buttons. On Windows it is visible, but not really pretty (a dotted gray border).

Requesting ui-review from Blake to have an answer about the other toolbar buttons, and review from Andreas to have an answer to the theming question, even though the current patch doesn't really touch theme files and we could take it as is for accessibility and fix the theme in a follow-up bug if needed.
Comment 4 Andreas Nilsson (:andreasn) 2012-05-30 07:07:00 PDT
On Windows, they way that Internet Explorer and File Explorer does it is that they use the same appearance as the hover for focus. That would look a bit nicer than the dotted border.
Comment 5 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-05-30 07:36:42 PDT
(In reply to Andreas Nilsson (:andreasn) from comment #4)
> On Windows, they way that Internet Explorer and File Explorer does it is
> that they use the same appearance as the hover for focus.

I've just tried on my Win7 VM and the 2 don't behave identically.
On the file explorer, the appearance of focused toolbar buttons is similar but not identical to focused toolbar buttons (easy to notice by hovering an already focused button). It seems the border is the same for both, but the hovered button has an additional background gradient.

IE (version 8.0 in my VM) has a strange focus behavior: the hovered buttons become focused; so hovered and focused seem to be the same state.

> That would look a bit nicer than the dotted border.

Yes, either appearance would look a bit better. Do you want to handle this in a separate bug? (this one was filed mostly for accessibility)
Comment 6 Andreas Nilsson (:andreasn) 2012-05-30 07:53:04 PDT
(In reply to Florian Quèze from comment #5)
> Yes, either appearance would look a bit better. Do you want to handle this
> in a separate bug? (this one was filed mostly for accessibility)

Might as well do, especially if we want to do this to the rest of Thunderbird as well, and not only the chat tab.

Filed bug #759752 for that.
Comment 7 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-05-31 06:01:16 PDT
Comment on attachment 628320 [details] [diff] [review]
Patch

Andreas plans to handle the theming issue in a separate bug, so the code review is now for Blake too :).
Comment 8 Blake Winton (:bwinton) (:☕️) 2012-05-31 10:31:44 PDT
Comment on attachment 628320 [details] [diff] [review]
Patch

> Should we do this for all toolbar buttons instead? (Is it the expected behavior
> that the toolbar buttons of the email tabs aren't focusable?)

(Curses, Aurora update killed my previous, stunningly informative and eloquent, comment.  So I guess we'll have to live with this one instead.  ;)

The code looks good, for what it does, so r=me on that bit, but...

After chatting with Marco, I hear the guideline to use is to add tabstops for only those buttons which don't have keyboard shortcuts or menu items.  (Because either of those two ways will be more efficient to navigate to the option than having to tab all around the UI.)

So, it makes sense to me to add a "Chat Contact" menu item below "File >> New >> Address Book Contact", and "Show Accounts" is already in "Tools >> Chat status >> Show Accounts", so I think we should just add a quick way of joining a chat, and not mark any of the buttons as tabbable.  (And perhaps we want to re-think where we've put the other menu options, since we have the chance to do that now.)

So I'm going to say ui-r- because I want to see what you come up with for the new menu options, but I suspect that'll be a fairly quick review.

Thanks,
Blake.
Comment 9 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-05-31 13:40:16 PDT
(In reply to Blake Winton (:bwinton - Thunderbird UX) from comment #8)

> So, it makes sense to me to add a "Chat Contact" menu item below "File >>
> New >> Address Book Contact"

Ok.

> "Show Accounts" is already in "Tools >> Chat status >> Show Accounts"

I think this could benefit from a keyboard shortcut. I keep hitting Command+shift+a which is the Instantbird shortcut for the same window. This shortcut doesn't seem to do anything currently in Thunderbird. Would this be a reasonable use for one of the last free key bindings? (I tend to think "no" as users don't really have good reasons to open this window frequently during normal use, but I would really like it for my testing :))

> we should just add a quick way of joining a chat,

What about "Tools >> Join Chat Room" immediately after "Tools >> Chat status"? I don't really like this proposition, but I can't seem to find anything better.

> (And perhaps
> we want to re-think where we've put the other menu options, since we have
> the chance to do that now.)

Are there some chat related menu options that you dislike?
Comment 10 Blake Winton (:bwinton) (:☕️) 2012-06-01 12:26:01 PDT
(In reply to Florian Quèze from comment #9)
> (In reply to Blake Winton (:bwinton - Thunderbird UX) from comment #8)
> > we should just add a quick way of joining a chat,
> What about "Tools >> Join Chat Room" immediately after "Tools >> Chat
> status"? I don't really like this proposition, but I can't seem to find
> anything better.

Yeah, I think that's better than "File >> New >> Chat Room" at least.

> > (And perhaps
> > we want to re-think where we've put the other menu options, since we have
> > the chance to do that now.)
> Are there some chat related menu options that you dislike?

Not off the top of my head, but now would be a good time to re-think them.  ;)
(What do we think about adding a "Chat" menu these days?)

Later,
Blake.
Comment 11 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-06-04 06:26:40 PDT
Created attachment 629754 [details] [diff] [review]
Patch v2
Comment 12 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-06-04 06:29:28 PDT
Rephrasing the summary to match what we are actually fixing here after comment 8.
Comment 13 Blake Winton (:bwinton) (:☕️) 2012-06-04 11:52:04 PDT
Comment on attachment 629754 [details] [diff] [review]
Patch v2

Okay, ui-r=me!  And it seems reasonable code-wise, so r=me, too.

I think we should check it in before the merge, but I'ld also like to hear Marco's opinion.
Marco: There are new menu items at the bottom of File - New, and in Tools.  Let me know what you think.  :)

Thanks,
Blake.
Comment 14 Marco Zehe (:MarcoZ) 2012-06-04 12:00:59 PDT
Comment on attachment 629754 [details] [diff] [review]
Patch v2

This looks great, thank you! f=me.
Comment 15 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-06-04 12:26:27 PDT
Thanks for the reviews and feedback!

https://hg.mozilla.org/comm-central/rev/b0b2a0e4aec2

Note You need to log in before you can comment on or make changes to this bug.