Repair Folder makes folder contents inaccessible

RESOLVED INVALID

Status

MailNews Core
Database
--
critical
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Sid Deb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Build ID: 20120215223356

Steps to reproduce:

A filter to move certain emails into a folder started to fail so I tried "Repair Folder" in the folder properties dialog.  


Actual results:

This made all the emails in that folder inaccessible, I can still see the count of messages in that folder, but none of the headers in the list or any of the messages.  This has happened twice with TB 10.


Expected results:

The emails in that folder should have remained readable instead of disappearing and the filter should have started working again.
(Reporter)

Updated

6 years ago
Severity: normal → critical
Priority: -- → P1
(Reporter)

Comment 1

6 years ago
This is an awful bug because I have lost some very important data.  We use Thunderbird on linux for our work email and I have lost several months worth of data because of this.

Comment 2

6 years ago
(In reply to Sid Deb from comment #1)

See if this can help: http://forums.mozillazine.org/viewtopic.php?f=31&t=1972607

Comment 3

6 years ago
David Bienvenu can probably help you what to do now. The data may still be recoverable, just do not compact or repair the folders again.
Component: General → Database
Product: Thunderbird → MailNews Core
QA Contact: general → database
(Reporter)

Comment 4

6 years ago
The forum post instructions didn't help. My corrupted mbox files have size 0 bytes, as does another seemingly healthy mbox, which has data when I look at that folder in TB.

The instructions in the forum post suggested I should compact all my folders, which I did, having tried the Repair a couple of times before I reported the bug.

Comment 5

6 years ago
compacting folders with corrupt db's is a bad idea, because it prevents recovering the data.
(Reporter)

Comment 6

6 years ago
Thanks for that timely tip. I was following the instructions posted above. 

Maybe the misinformation that's out there on mozillazine needs to be updated?

So have I lost my data?

Comment 7

6 years ago
I would think so, but mozillazine is not affiliated with Mozilla. I would suggest complaining to them.

Yes, I'm sorry, if the mbox files are 0 bytes, then your messages are not in them. If you don't have a backup, and leave your messages on the pop3 server, you can redownload the messages still on the server by shutting down thunderbird, deleting the popstate.dat file from your mail server sub-directory of your profile, and restarting Thunderbird.
(Reporter)

Comment 8

6 years ago
The comment earlier suggested I go to mozillazine, so I did.  I'd like to complain about that advice.

My mail is imap based, is there a way to recover it in that case?

Comment 9

6 years ago
Is your mail really on an imap server? If so, and repair folder didn't help, then your mail was deleted from your imap server. Compact doesn't affect what's on the imap server, unless the messages have already been deleted.

Comment 10

6 years ago
(In reply to Sid Deb from comment #4)
> The forum post instructions didn't help. My corrupted mbox files have size 0
> bytes, as does another seemingly healthy mbox, which has data when I look at
> that folder in TB.
> 
> The instructions in the forum post suggested I should compact all my
> folders, which I did, having tried the Repair a couple of times before I
> reported the bug.

I am sorry to know that! But the link I posted suggests you first back up before attempting to repair the folder. You should have done that.
(Reporter)

Comment 11

6 years ago
I actually did make a backup, but when I checked it, the mboxes for the 2 corrupted folders aren't there, even though their msf files are.

My email really is from an imap server and repair folder didn't repair my folder, it actually seemed to corrupt it some more.  The messages that disappeared weren't deleted messages, and compact didn't seem to make a difference to the corrupted folders, but it did free up some space. yay.

Comment 12

6 years ago
The commenters were all assuming pop3/local messages, because of the symptoms, and you didn't specifically mention imap until now. Something has gone wrong on your imap server, beyond the control of Thunderbird to control. Do you administrate your server, or is it a 3rd-party server?
(Reporter)

Comment 13

6 years ago
I don't personally administrate our email server but it is in house.  Is recovery possible on the server?

Comment 14

6 years ago
(In reply to Sid Deb from comment #13)
> I don't personally administrate our email server but it is in house.  Is
> recovery possible on the server?

That would be a question for your server admin - this doesn't sound like a client issue. The imap client shows you what's on the server, and if what's on the server is broken, that's what the client shows.

Comment 15

6 years ago
please reopen if you find the fault lies with Thunderbird.
ATM, doesn't sound like thunderbird
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Priority: P1 → --
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.