If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

DCC Accept/Decline Dialog not working

RESOLVED DUPLICATE of bug 736300

Status

Other Applications
ChatZilla
RESOLVED DUPLICATE of bug 736300
6 years ago
6 years ago

People

(Reporter: jkaelin, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

ChatZilla 0.9.88.1 [Firefox 11.0/20120312181643]

Request XDCC transfer from bot on IRC. Clicked Accept to receive DCC transfer.


Actual results:

Chatzilla displays Accept/Decline Dialog, choosing either option has no effect.

CS|Tori	XDCC SEND 992
	CS|Tori	** Sending you pack #992 ("[Commie] Persona 4 - 15 [AAE8B770].mkv"), which is 211MB. (resume supported)
	[DCC]	Got DCC File Transfer offer from “CS|Tori” (94.242.209.233:42213) of “[Commie] Persona 4 - 15 [AAE8B770].mkv” (211 MiB) [Accept] [Decline].
	[DCC]	Got DCC File Transfer offer from “CS|Tori” (94.242.209.233:42213) of “[Commie] Persona 4 - 15 [AAE8B770].mkv” (211 MiB) [Accept] [Decline].
	CS|Tori	** You have a DCC pending, Set your client to receive the transfer. Type "/MSG CS|Tori XDCC CANCEL" to abort the transfer. (150 seconds remaining until timeout)
	CS|Tori	XDCC cancel
	CS|Tori	** Closing Connection: Transfer canceled by user
	[DCC]	Aborted DCC File Transfer of “[Commie] Persona 4 - 15 [AAE8B770].mkv” from “CS|Tori” (97.69.174.18:42213).
	[DCC]	Aborted DCC File Transfer of “[Commie] Persona 4 - 15 [AAE8B770].mkv” from “CS|Tori” (97.69.174.18:42213).

Also, Chatzilla displays DCC Abort message twice, maybe from each attempt by the bot to push DCC through.


Expected results:

DCC transfer should have started when I clicked Accept, or stopped when I hit Decline.

I was able to complete a DCC transfer when I added the bot to auto-accept list, indicating issue is with the Dialog.

Comment 1

6 years ago
Please get a nightly build from http://james-ross.co.uk/mozilla/chatzilla/nightly/ if you wish to continue using Firefox 11 until the next release of ChatZilla.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 736300
You need to log in before you can comment on or make changes to this bug.