Filter page-mod by frame parent in addition to URL

RESOLVED DUPLICATE of bug 684047

Status

Add-on SDK
General
P2
normal
RESOLVED DUPLICATE of bug 684047
6 years ago
5 years ago

People

(Reporter: Michael Balazs, Assigned: irakli)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120321033733

Steps to reproduce:

Feature Request: For content scripts loaded with page-mod into iframes, it would be nice to filter by window.top.location.href as well.
Assignee: nobody → rFobic
Irakli will think about this
Assignee: rFobic → nobody
Whiteboard: [triage:followup]
(Reporter)

Comment 2

6 years ago
Thanks Dave. The reasoning behind this is my addon (Integrated Gmail) is being migrated to use the SDK in hopes of improving performance (speed and memory). IG works by loading iframes in gmail into which additional content scripts are loaded. We don't want them loading if gmail is not the parent frame. It is possible to have the script just return if this not the case but would prefer to not have it load at all.
Assignee: nobody → rFobic
Depends on: 708190
Priority: -- → P2
Whiteboard: [triage:followup]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 684047
You need to log in before you can comment on or make changes to this bug.