{inc} Box acid test renders incorrectly (margin reflow issue)

VERIFIED FIXED in M11

Status

()

Core
Layout
P4
minor
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: kbaker, Assigned: buster)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
On the M6 build (5/29/1999 PC, on Windows NT 4.0 SP3), visiting the box acid test yields an incorrect result.  The above URL will take you there.

Updated

18 years ago
Component: Apprunner → Layout
QA Contact: leger → petersen

Comment 1

18 years ago
petersen, do you see this too with today's build?  All platforms?

Updated

18 years ago
Assignee: don → rickg

Updated

18 years ago
Assignee: rickg → peterl

Comment 2

18 years ago
Peter: can you please diagnose this problem?

Updated

18 years ago
Assignee: peterl → troy

Comment 3

18 years ago
The body frame isn't getting the right height on the initial reflow.
See also bug 6153 and bug 7656.

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 5

18 years ago
Yup, when the window is resized the body height is correct. Looks like an
incremental reflow bug...

Comment 6

18 years ago
*** Bug 7656 has been marked as a duplicate of this bug. ***
See bug 4572 for more info on this problem.  That's actually the only other open
bug relating to the boxacidtest(, I think).  The WONTFIXed bug 4098 is also
related to the boxacidtest.
Blocks: 8914

Comment 8

18 years ago
*** Bug 8711 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Assignee: troy → kipp
Status: ASSIGNED → NEW

Comment 9

18 years ago
Kipp, this looks like a block incremental reflow bug

Updated

18 years ago
Severity: normal → minor
Status: NEW → ASSIGNED
Priority: P3 → P4
Target Milestone: M11

Comment 10

18 years ago
*** Bug 12054 has been marked as a duplicate of this bug. ***
*** Bug 11896 has been marked as a duplicate of this bug. ***
Summary: Box acid test renders incorrectly → {inc}Box acid test renders incorrectly
*** Bug 13632 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Summary: {inc}Box acid test renders incorrectly → {inc} Box acid test renders incorrectly (margin reflow issue)

Comment 13

18 years ago
There is a slight margin problem at the bottom between the text describing the
test and the test...It goes away when you resize the window.

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 14

18 years ago
Fix just landed.
Status: RESOLVED → VERIFIED
Verified fixed 1999-09-16-08-M11 Linux.  I think when kipp said "just" he meant
"yesterday".  (I see the bug in 1999-09-14-09-M11.)

Comment 16

18 years ago
Take a look at the box-acid test now in the newest  December 30th build of
Mozilla.  The last large black box with the words "sing to me, erbarme dich"
shows up outside of the black border that it is supposed to be within.  Mozilla
passed this test until just recently.  The last couple builds I have viewed this
with have broken the box model.

I will let someone else actually reopen this bug if they deem it to be worthy of
reopening.  I don't think David Baron was too happy with me the last time I
reopened one, so I'll let him decide.

Jake
You need to log in before you can comment on or make changes to this bug.