Closed Bug 74017 Opened 24 years ago Closed 24 years ago

Trunk crash [@ gklayout.dll + 0x23471 or nsImageFrame::Paint] when scroll down on that page

Categories

(Core :: Graphics: ImageLib, defect)

x86
All
defect
Not set
critical

Tracking

()

VERIFIED FIXED

People

(Reporter: Matti, Assigned: pavlov)

References

()

Details

(Keywords: crash, topcrash, Whiteboard: [imglib])

Crash Data

Attachments

(1 file)

build 2001032804/win2k

Mozilla crash if I click on "about:1994" or another not working link on that
page und scroll down after I clicked on that link.

TB#: TB28432441Q

I don´t know where mozilla crash, seem to be layout 
(after Drwatson:gklayout!NS_NewPresShell ) 
but someone shut extract the talkback.
My first comment is wrong.
Mozilla crash if I scroll down. This has nothing to do if I click the link or 
not.

Summary: crash when click on about:1994 and scroll down → crash when scroll down on that page
Also crashes for me with 2001032904 / Win98SE.
Works For Me in Linux
Must only be in windows

Build 2001032821
-> libpr0n crash
Assignee: asa → pavlov
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: Browser-General → ImageLib
Ever confirmed: true
Keywords: crash
OS: Windows 2000 → All
QA Contact: doronr → tpreston
Attached file stack trace
This may be useful for the engineer who attempts to fix this bug:

'this' is null, when the call:
http://lxr.mozilla.org/seamonkey/source/layout/html/base/src/nsImageFrame.cpp#967 
is made. 

And thus it crashes, because nsImageFrame::mImageRequest is null at the time
it's called.


I'm also crashing there a lot, so take this as high priority
Still crashing W2k build 2001040304  Attaching call stack  

   gklayout.dll + 0x23471 (0x60323471) 
 
   gklayout.dll + 0x1dd68 (0x6031dd68) 

   gklayout.dll + 0x2e362 (0x6032e362) 
 
   gklayout.dll + 0x2e274 (0x6032e274) 
 
   gklayout.dll + 0x1dd68 (0x6031dd68) 
 
   gklayout.dll + 0x2e362 (0x6032e362) 
 
   gklayout.dll + 0x2e274 (0x6032e274) 
 
   gklayout.dll + 0x1dd68 (0x6031dd68) 
 
   gklayout.dll + 0x2e362 (0x6032e362) 
 
   gklayout.dll + 0x2e274 (0x6032e274) 
 
   gklayout.dll + 0x1dd68 (0x6031dd68) 
 
   gklayout.dll + 0x1dcab (0x6031dcab) 
 
   gklayout.dll + 0x2188a (0x6032188a) 
 
   gklayout.dll + 0x1b59d (0x6031b59d) 
 
   gkview.dll + 0x1319 (0x60441319) 
 
   gkview.dll + 0x661e (0x6044661e) 
 
   gkview.dll + 0x5e69 (0x60445e69) 
 
   gkview.dll + 0x5abe (0x60445abe) 
 
   gkview.dll + 0x7416 (0x60447416) 
 
   gkview.dll + 0x1d7d (0x60441d7d) 
 
   gkwidget.dll + 0x4ece (0x60b94ece) 
 
   gkwidget.dll + 0x4f37 (0x60b94f37) 
 
   gkwidget.dll + 0x777c (0x60b9777c) 
 
   gkwidget.dll + 0x6798 (0x60b96798) 
 
   gkwidget.dll + 0x535c (0x60b9535c) 
 
   USER32.DLL + 0x3eb0 (0x77e13eb0) 
 
   USER32.DLL + 0x591b (0x77e1591b) 
 
   USER32.DLL + 0x595d (0x77e1595d) 
 
   ntdll.dll + 0x1fb83 (0x77f9fb83) 
 
   gkview.dll + 0x2c56 (0x60442c56) 
 
   gkview.dll + 0x2818 (0x60442818) 
 
   gklayout.dll + 0x8da4a (0x6038da4a) 
 
   gklayout.dll + 0x8d216 (0x6038d216) 
 
   gkcontent.dll + 0xa267 (0x601ea267) 
 
   gkcontent.dll + 0x4848b (0x6022848b) 
 
   gkcontent.dll + 0xd8d62 (0x602b8d62) 
 
   gkcontent.dll + 0xd8e59 (0x602b8e59) 
 
   gklayout.dll + 0x73421 (0x60373421) 
 
   gklayout.dll + 0x72ecc (0x60372ecc) 
 
   gklayout.dll + 0x1babe (0x6031babe) 
 
   gklayout.dll + 0x1b90b (0x6031b90b) 
 
   gkview.dll + 0x146b (0x6044146b) 
 
   gkview.dll + 0x7237 (0x60447237) 
 
   gkview.dll + 0x1d7d (0x60441d7d) 
 
   gkwidget.dll + 0x4ece (0x60b94ece) 
 
   gkwidget.dll + 0x4f14 (0x60b94f14) 
 
   gkwidget.dll + 0x7a7c (0x60b97a7c) 
 
   gkwidget.dll + 0x7e4d (0x60b97e4d) 
 
   gkwidget.dll + 0x7081 (0x60b97081) 
 
   gkwidget.dll + 0x535c (0x60b9535c) 
 
   USER32.DLL + 0x3eb0 (0x77e13eb0) 
 
   USER32.DLL + 0x401a (0x77e1401a) 
 
   USER32.DLL + 0x92da (0x77e192da) 
 
   appshell.dll + 0x61dc (0x600961dc) 
 
   netscp6.exe + 0x16ec (0x004016ec) 
 
   netscp6.exe + 0x11b8 (0x004011b8) 
 
   netscp6.exe + 0x2c28 (0x00402c28) 
 
   KERNEL32.DLL + 0x7903 (0x77e87903) 
Whiteboard: [imglib]
someone fixed this the other day.  marking worksforme
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → WORKSFORME
I still see this crash on WIN2k, build 20010409.. 02PM (CVS debug)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Adding topcrash and [@ gklayout.dll + 0x23471] for tracking...since this is 
showing up in the latest talkback reports. Not sure how many crashes exactly 
since the stack trace isn't very helpful without symbols, but here is the one 
entry i did find that mentioned this bug:

gklayout.dll + 0x23471 (0x60323471) 4577aba7
         line 
        Build: 2001040306 CrashDate: 2001-04-03 UptimeMinutes: 68  Total: 89 
        OS: Windows NT  5.0 build 2195
        URL: http://rigaut.home.cern.ch/rigaut/about.html
        Comment: Trying to verify that bug 74017 is still a bug
         Detailed : http://cyclone/reports/incidenttemplate.cfm?bbid=28626798
         StackTrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=28626798

Here are a few more entries with the exact same stack signature with offset 
(which probably indicates the same crash):

gklayout.dll + 0x23471 (0x60323471) cdfd8fdf
         line 
        Build: 2001040309 CrashDate: 2001-04-03 UptimeMinutes: 19  Total: 19 
        OS: Windows NT  4.0 build 1381
        URL: 
        Comment: Fails consistently on 'Technology Update' e-mail from wsj.com
         Detailed : http://cyclone/reports/incidenttemplate.cfm?bbid=28634853
         StackTrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=28634853

gklayout.dll + 0x23471 (0x60323471) 59680837
         line 
        Build: 2001040306 CrashDate: 2001-04-03 UptimeMinutes: 17  Total: 54 
        OS: Windows NT  5.0 build 2195
        URL: news.webking.com.cn
        Comment: 
         Detailed : http://cyclone/reports/incidenttemplate.cfm?bbid=28636643
         StackTrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=28636643
Keywords: topcrash
Summary: crash when scroll down on that page → crash [@ gklayout.dll + 0x23471] when scroll down on that page
I'm seeing this on w98 build 2001041104
*** Bug 74891 has been marked as a duplicate of this bug. ***
methinks this would cover the crashes in nsImageFrame::Paint seen in other bugs
loading pages --but pls lemme know if i'm wrong!
Summary: crash [@ gklayout.dll + 0x23471] when scroll down on that page → crash [@ gklayout.dll + 0x23471, or nsImageFrame::Paint] when scroll down on that page
*** Bug 75894 has been marked as a duplicate of this bug. ***
Updating summary with "Trunk", since this is a topcrasher with the latest trunk 
builds.  Also, if someone can take a look at bug 36902 and see if it's a dup of 
this one, that would be great!
Summary: crash [@ gklayout.dll + 0x23471, or nsImageFrame::Paint] when scroll down on that page → Trunk crash [@ gklayout.dll + 0x23471 or nsImageFrame::Paint] when scroll down on that page
neither se or I were able to reproduce this.  People are still seeing this 
crash?
I can´t see a crash with win2k build 20010416.. (CVS debug, 11pm).
My opt. build from 20010414.. crashed there.

WFM now ! 
marking worksforme
Status: REOPENED → RESOLVED
Closed: 24 years ago24 years ago
Resolution: --- → WORKSFORME
How safe is it really, to mark this worksforme when it only two days ago was
considered a topcrash in talkbacks?

Shouldn't you wait a while before closing this?
jay, can you have a look at the latest talkback data and see if this
has gone away?  if it has mark it fixed
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
The gklayout.dll crash is definitely off the topcrash radar and it looks like 
the nsImageFrame::Paint crash stopped occurring after the 2001041322 build, so 
marking fixed.
Status: REOPENED → RESOLVED
Closed: 24 years ago24 years ago
Resolution: --- → FIXED
Verified fixed on w2k build 2001041704
Verified fixed on linux build 2001041708
Verified fixed on mac 2001041704
Status: RESOLVED → VERIFIED
Crash Signature: [@ gklayout.dll + 0x23471 or nsImageFrame::Paint]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: