Last Comment Bug 740191 - [Skia] Fix SkBlitRow_opts_arm.cpp for compiling with NEON and Thumb enabled.
: [Skia] Fix SkBlitRow_opts_arm.cpp for compiling with NEON and Thumb enabled.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla14
Assigned To: George Wright (:gw280) (:gwright)
:
Mentors:
Depends on:
Blocks: skia-android 687187
  Show dependency treegraph
 
Reported: 2012-03-28 16:01 PDT by George Wright (:gw280) (:gwright)
Modified: 2012-03-29 08:50 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix skblitrow (1.13 KB, patch)
2012-03-28 16:05 PDT, George Wright (:gw280) (:gwright)
matt.woodrow: review+
Details | Diff | Review

Description George Wright (:gw280) (:gwright) 2012-03-28 16:01:17 PDT
Currently if we try to compile with NEON and Thumb enabled, SkBlitRow_opts_arm.cpp fails to compile because we are using a conditional instruction without an if-then instruction.

This is being tracked upstream at http://codereview.appspot.com/5649055
Comment 1 George Wright (:gw280) (:gwright) 2012-03-28 16:05:18 PDT
Created attachment 610341 [details] [diff] [review]
Fix skblitrow

Add a Thumb IT instruction before MOVEQ to fix compile error. Patch from http://codereview.appspot.com/5649055/
Comment 2 George Wright (:gw280) (:gwright) 2012-03-28 19:24:08 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/b6a1c1c85ca3
Comment 3 Matt Brubeck (:mbrubeck) 2012-03-29 08:50:01 PDT
https://hg.mozilla.org/mozilla-central/rev/b6a1c1c85ca3

Note You need to log in before you can comment on or make changes to this bug.