Keep Post Moz 0.6 browsers from downloading new themes for 0.6+

VERIFIED FIXED

Status

SeaMonkey
Installer
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: Patty Mac, Assigned: Todd Pringle)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: netscape.com)

(Reporter)

Description

17 years ago
Platform: All (2001-03-29-04-Mtrunk).

Steps to reproduce:

1. Launch the browser using (2001-03-29-04-Mtrunk)--> get this from
   ftp://sweetlou....
2. Go to View > Apply Theme > Get New Themes...
3. Choose any theme that you want to install (i.e; I choose sky-pilot)
   and click on "Import Theme" button.
4. The warning dialog displays "uncompatible browser"
(Reporter)

Comment 1

17 years ago
Adding keyword: nsbeta1
Keywords: nsbeta1
(Assignee)

Comment 2

17 years ago
Patty, I believe this is the proper behavior.  Dave Hyatt I believe has
implemented this in current builds such that you can no longer use or install
themes designed for 6.0.  In other words, because these 6.0 themes no longer
work properly with daily builds, you cannot:

a)  switch to a 6.0 theme (Sky Pilot, grrly, etc.) if you had it previously
installed on your machine, or
b)  install a 6.0 theme from the theme park or anywhere else on a daily build.

This is the proper behavior, though we need to install proper dialogs telling
the user what the problem is. Dave, can you confirm?
(Reporter)

Comment 3

17 years ago
Thanks Todd!
(Assignee)

Comment 4

17 years ago
So it looks like I presumed too much.  I talked to Dave today and he in fact has
not implemented theme versioning.  So in other words, this SHOULD still work.  

Comment 5

17 years ago
Problems related to installation of themes don't go to the Themes component.  
Moving to Installer component.
Assignee: hewitt → ssu
Component: Themes → Installer
QA Contact: pmac → gemal
Isn't this coding on the site side, an attempt to protect mozilla/mojo users 
from downloading chrome that we *know* doesn't work?

The feature Hyatt is going to add will only prevent people from switching to an 
already-installed theme. To keep people from wasting all the download time 
only to be disappointed sites will have to do some version checking as well.

Reassigning to rebron on the site side, but I suspect this is as-designed.
Assignee: ssu → rebron
(Assignee)

Comment 7

17 years ago
Good point - I wasn't aware they had implemented this yet, but maybe they have.
 Rafael?

Comment 8

17 years ago
who should be qa on this one? Not me... I'm qa on the win32 installer, and this 
is not a win32 installer problem...

Updated

17 years ago
QA Contact: gemal → blakeross
(Reporter)

Comment 9

17 years ago
Taking..I'm the QA for this one.
Reassigning to Edmundo.  Changing summary from 
"Unable to install all the themes from the theme park"

to "Keep Post Moz 0.6 browsers from downloading new themes for 0.6+ browsers"

Desired outcome.  
Let Mozilla 0.6 RTM browsers download 0.6 RTM themes.  
Let Mozilla 0.9.? RTM browsers download 0.9.? RTM themes.

We should attach the theme park sniff with this bug so other folks who want to
have a "theme park" can use the sniff.
Assignee: rebron → edmundo
Summary: Unable to install all the themes from the theme park → Keep Post Moz 0.6 browsers from downloading new themes for 0.6+
Whiteboard: netscape.com

Comment 11

17 years ago
Okay, QA -> Patty
QA Contact: blakeross → pmac

Comment 12

17 years ago
Working on this on the theme park site side.  A 6.5 Theme Park index page will 
be in place by beta launch.  There will be verbage on this page and the current 
Theme Park index page notifying users that there will be new 6.5 themes coming 
and that their current themes are incompatible with 6.5.  There will also be a 
sniff in the page which makes sure that 6.5 users get sent to the appropriate 
theme park and there will be a dialog box which shows up when a 6.5 user 
attempts to install a 6/6.01 theme from the Theme Park.

On the client side, when a user upgrades to 6.5, they will still see their 
previously installed themes available in the "View -> Apply Theme" menu, but
when the user attempts to switch, there will be a dialog box that will appear 
giving theme the reason why they're unable to switch to their 6/6.01 theme(s).  
That's my understanding at least...


Updated

17 years ago
Blocks: 104166

Updated

17 years ago
Keywords: nsbeta1

Comment 13

17 years ago
dveditz suggests that you are the person to find a home for this bug.  It does't
look like an installer bug, and edmundo isn't around to talk to.  Thanks.
Assignee: edmundo → tpringle
(Assignee)

Comment 14

17 years ago
This should be fixed via a sniff on the theme park.  Marking as such.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

16 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.