Segfault with proxy authentification

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
--
critical
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Jonathan D., Unassigned)

Tracking

({crash})

14 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [need stack trace from the reporter] [testday-20120615])

Attachments

(1 attachment)

267.19 KB, application/octet-stream
Details
(Reporter)

Description

6 years ago
Created attachment 610468 [details]
strace log

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120322104949

Steps to reproduce:

Open current firefox nightly (ubuntu build from PPA-14.0~a1~hg20120327r90396-0ubuntu1~umd1~oneiric).



Actual results:

Firefox crash immediately.
When launched from command line, the appearing error is a segfault.

It only appends at work.
I've done a little strace and it shows the segfault happens just after receiving a response from the proxy "HTTP/1.0 407 Proxy Authentication".
It happens also in safe mode and with a new empty profile.



Expected results:

Firefox nightly should open normally.
(Reporter)

Updated

6 years ago
Severity: normal → blocker

Comment 1

6 years ago
Does the segfault occur with a Mozilla build?
Severity: blocker → critical
Keywords: crash
(Reporter)

Comment 2

6 years ago
Yes, it also happens on today's version downloaded on http://nightly.mozilla.org/
It triggers Crash reporter which can not submit the data (doesn't use proxy settings ?).

The detail button in the crash reporter gives this information:

BuildID: 20120329031156
CrashTime: 1333101681
EMCheckCompatibility: true
Email: jonathand131@gmail.com
FramePoisonBase: 00000000f0dea000
FramePoisonSize: 4096
InstallTime: 1333101262
Notes: OpenGL: ATI Technologies Inc. -- ATI Radeon HD 4550    -- 3.3.11005 Compatibility Profile Context -- texture_from_pixmap

ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
ProductName: Firefox
ReleaseChannel: nightly
SecondsSinceLastCrash: 8
StartupTime: 1333101677
Theme: classic/1.0
Throttleable: 1
URL: https://www.rememberthemilk.com/home/jonathand131/#section.tasks
Vendor: Mozilla
Version: 14.0a1

Comment 3

6 years ago
Since the crash reporter doesn't work for you, could you maybe try this https://wiki.ubuntu.com/MozillaTeam/Bugs#Run_Firefox_in_a_Debugger to get a stack trace? Right now we know it crashes for you, but there's little information available to identify and fix the problem.
Whiteboard: [need stack trace from the reporter]
(Reporter)

Comment 4

6 years ago
I did had time to reproduce the problem.

With the latest nightly, it doesn't happens anymore but I had to use a new (clean) profile.
With my old profile, the pages were loading indefinitely even in safe mode.

Do you still need a crash dump or do you want to close this bug ?

Regards.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [need stack trace from the reporter] → [need stack trace from the reporter] [testday-20120615]
You need to log in before you can comment on or make changes to this bug.