compartments are not freed too long with Adblock Plus

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Sergey, Unassigned)

Tracking

13 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [have contact with ABP author])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120318 Firefox/13.0a2
Build ID: 20120318042011

Steps to reproduce:

Normal daily usage.


Actual results:

Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120318 Firefox/13.0a2 - Build ID: 20120318042011

Some compartments stay in memory up to 4-5 hours.

about:compartments:

about: [2]
about:blank [9]
http://habrahabr.ru/post/140857/ [4]
http://habrahabr.ru/post/140961/ [3]
http://itsmweb-xxx.xxx.xx/arsys/shared/login.jsp?/arsys/home [2] -- about 5 hours
http://itsmweb-xxx.xxx.xx/arsys/shared/logout.jsp -- about 5 hours
http://www.sonymobile.com/gb/products/phones/xperia-s/
http://www.sonymobile.com/ru/products/accessories/xperia-smarttags/specifications/
http://www.sonymobile.com/ru/products/phones/xperia-p/

https://dpadm-xxx.xxx.xx:9090/filesyshelp.html -- about 4 hours
https://dpadm-xxx.xxx.xx:9090/login.xml?session=false -- about 4 hours


│  ├────1,989,232 B (00.65%) -- compartment(http://itsmweb-xxx.xxx.xx/arsys/shared/login.jsp?/arsys/home)
│  │    ├──1,200,128 B (00.39%) -- gc-heap
│  │    │  ├────678,840 B (00.22%) -- arena
│  │    │  │    ├──661,152 B (00.22%) ── unused [2]
│  │    │  │    ├────9,376 B (00.00%) ── headers [2]
│  │    │  │    └────8,312 B (00.00%) ── padding [2]
│  │    │  ├────304,344 B (00.10%) -- shapes
│  │    │  │    ├──175,800 B (00.06%) ── dict [2]
│  │    │  │    ├───72,464 B (00.02%) ── base [2]
│  │    │  │    └───56,080 B (00.02%) ── tree [2]
│  │    │  ├────196,912 B (00.06%) -- objects
│  │    │  │    ├──165,280 B (00.05%) ── function [2]
│  │    │  │    └───31,632 B (00.01%) ── non-function [2]
│  │    │  ├─────14,208 B (00.00%) ── type-objects [2]
│  │    │  ├──────5,600 B (00.00%) ── scripts [2]
│  │    │  ├────────160 B (00.00%) ── xml
│  │    │  └─────────64 B (00.00%) ── strings
│  │    ├────393,216 B (00.13%) -- mjit
│  │    │    └──393,216 B (00.13%) ── code [2]
│  │    ├────185,536 B (00.06%) -- shapes-extra
│  │    │    ├───92,928 B (00.03%) ── compartment-tables [2]
│  │    │    ├───83,616 B (00.03%) ── dict-tables [2]
│  │    │    ├────5,920 B (00.00%) ── tree-tables
│  │    │    └────3,072 B (00.00%) ── tree-shape-kids [2]
│  │    ├────102,240 B (00.03%) ── analysis-temporary
│  │    ├─────49,856 B (00.02%) -- type-inference
│  │    │     ├──28,832 B (00.01%) ── object-main
│  │    │     ├──20,928 B (00.01%) ── tables
│  │    │     └──────96 B (00.00%) ── script-main
│  │    ├─────47,072 B (00.02%) -- objects
│  │    │     ├──43,200 B (00.01%) ── slots [2]
│  │    │     ├───3,424 B (00.00%) ── elements [2]
│  │    │     └─────448 B (00.00%) ── misc [2]
│  │    └─────11,184 B (00.00%) ── script-data [2]


│  ├────1,010,360 B (00.33%) -- compartment(https://dpadm-xxx.xxx.xx:9090/login.xml?session=false)
│  │    ├────516,096 B (00.17%) -- gc-heap
│  │    │    ├──340,240 B (00.11%) -- arena
│  │    │    │  ├──332,664 B (00.11%) ── unused
│  │    │    │  ├────4,032 B (00.00%) ── headers
│  │    │    │  └────3,544 B (00.00%) ── padding
│  │    │    ├──115,328 B (00.04%) -- shapes
│  │    │    │  ├───77,000 B (00.03%) ── dict
│  │    │    │  ├───29,008 B (00.01%) ── base
│  │    │    │  └────9,320 B (00.00%) ── tree
│  │    │    ├───57,744 B (00.02%) -- objects
│  │    │    │   ├──53,248 B (00.02%) ── function
│  │    │    │   └───4,496 B (00.00%) ── non-function
│  │    │    ├────2,112 B (00.00%) ── type-objects
│  │    │    └──────672 B (00.00%) ── scripts
│  │    ├────327,680 B (00.11%) -- mjit
│  │    │    └──327,680 B (00.11%) ── code
│  │    ├────145,728 B (00.05%) -- shapes-extra
│  │    │    ├──106,752 B (00.03%) ── compartment-tables
│  │    │    ├───37,216 B (00.01%) ── dict-tables
│  │    │    ├────1,088 B (00.00%) ── tree-tables
│  │    │    └──────672 B (00.00%) ── tree-shape-kids
│  │    ├─────14,040 B (00.00%) -- objects
│  │    │     ├──13,888 B (00.00%) ── slots
│  │    │     └─────152 B (00.00%) ── misc
│  │    ├──────6,496 B (00.00%) -- type-inference
│  │    │      └──6,496 B (00.00%) ── tables
│  │    └────────320 B (00.00%) ── script-data


Expected results:

Compartments should be freed with time.
(Reporter)

Comment 1

6 years ago
Adblock Plus 1.2.2true
Add Bookmark Here ² 4.0.20111125 true
Element Properties 6 true
Ez Sidebar 3.1.2008052801 true
FoxyProxy Standard 3.4 true
Ghostery 2.7.2 true
Hide Menubar 6.0.20110915 true
Mouse Gestures Redox 3.2pre.20110922 true
Movable Firefox Button 1.4 true
MR Tech Toolkit 6.0.4 true
NewsFox 1.0.8.3.3 true
NoScript 2.3.5 true
Nuke Anything Enhanced 1.0.2 true
Rotate Image 0.1.3.2 true
RSS Icon 1.0.6 true
Russian/English spell dictionary 1.0.0.1 true
Scriptish 0.1.7 true
SmartSearch 3.19 true
Stylish 1.2.6 true
Undo Closed Tabs Button 3.7.1 true
UnMHT 5.7.2 true
User Agent Switcher 0.7.3 true
Collusion 0.16.2 false
Custom Buttons 0.0.5.5 false
DownloadHelper 4.9.5 false
Element Hiding Helper for Adblock Plus 1.1.5a.355 false
ImgLikeOpera 0.6.21 false
Multi Smart Search 2.0.20110408 false
Nice Translator 0.5 false
openSUSE Firefox Extensions 1.0.1 false
Stylish-Custom 0.7.7 false
Test Pilot 1.22 false
United States English Spellchecker 5.0.1 false
XPath Checker 0.4.4 false
Yet Another Remove It Permanently 0.2 false

Comment 2

6 years ago
Have you tested WITHOUT addons (in Safe Mode) ? Most problems like this are caused by addons.
(Reporter)

Comment 3

6 years ago
Looks like I should report to AdBlock author :(
Sorry.
If I understand correctly, your two test pages are intranet sites? That makes it pretty impossible to reproduce the issue. Do you hit the issue on any public sites as well?
Just to be certain: did you reproduce this issue with Adblock Plus as the *only* enabled add-on?
(Reporter)

Comment 6

6 years ago
(In reply to Wladimir Palant from comment #5)
> Just to be certain: did you reproduce this issue with Adblock Plus as the
> *only* enabled add-on?

I will check shortly. Right now. With latest dev build it looks picture some way transformed.
(Reporter)

Comment 7

6 years ago
Well... What I've found.

I ADBP is ONLY extension is enabled situation look like this:
(I switched to public sites, but on intra a see the same)
1. Open Gmail page
2. Open Google+ in new window from Gmail page.
3. Close G+ window
4. G+ Compartment not freed.
5. Close Gmail page
6. Gmail compartment get freed, but not G+.

In safe mode all goes right way.
There is no guarantee that the compartment is freed right away. Did you press "Minimize memory use" on about:memory?
(Reporter)

Comment 9

6 years ago
Yes, I did. But G+ does not disappear.

Comment 10

6 years ago
(Since the only thing that can happen here is that Wladimir figures this out, updating the status whiteboard, so that this doesn't look untriaged.)
Summary: compartments are not freed too long → compartments are not freed too long with Adblock Plus
Whiteboard: [have contact with ABP author]
(Reporter)

Comment 11

6 years ago
(In reply to Wladimir Palant from comment #8)
> There is no guarantee that the compartment is freed right away. Did you
> press "Minimize memory use" on about:memory?

Were the problem by Gmail scenario reproducible ?
(Reporter)

Comment 12

6 years ago
After landing https://bugzilla.mozilla.org/show_bug.cgi?id=695480
my report makes no sense. Plz mark as required.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.