translate3d incorrect z translation placement

RESOLVED DUPLICATE of bug 726766

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 726766
6 years ago
6 years ago

People

(Reporter: Jeremy Harris, Unassigned)

Tracking

({css3, testcase})

Trunk
x86
Windows 7
css3, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

6 years ago
Created attachment 610557 [details]
z.html

User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.83 Safari/535.11

Steps to reproduce:

Using translate3d to move objects in 3d space can produce unexpected results on Firefox 11 for Windows. I was playing with translate3d, specifically using jmpress[1] and noticed some elements were upside down when viewing in Firefox.

A test case is attached and available on github[2]. You'll notice that in Firefox for Windows "Bar" appears on screen upside down, when it it outside what should be viewable. 

1: https://github.com/shama/jmpress.js/
2: https://gist.github.com/2032026


Actual results:

Elements outside of the viewer's viewable z-space were rendered upside down on the screen. It appears that if the z translation is set to something greater than the perspective + the parent's translate (the viewport), Firefox renders the item upside down at the negative z difference.


Expected results:

The elements should be outside of the viewing space and therefore should not appear.

This only appears to be an issue with Firefox for Windows. Webkit browsers and Firefox for Mac appear to render it correctly.
(Reporter)

Updated

6 years ago
Keywords: css3

Updated

6 years ago
Attachment #610557 - Attachment mime type: text/plain → text/html

Comment 1

6 years ago
Can you attach a screenshot of the issue?

Can you also test with the latest nightly? It may have been fixed already

Unable to reproduce on Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20120329 Firefox/14.0a1 ID:20120329031156
(Reporter)

Comment 2

6 years ago
Created attachment 610705 [details]
screenshot
(Reporter)

Comment 3

6 years ago
Added screenshot. I also just tested on the latest nightly (14.0a1) and it rendered the same as Fx 11.

Comment 4

6 years ago
Please post the contents of about:support as a text attachment to this bug

Comment 5

6 years ago
Created attachment 610725 [details]
bug740382-capture-ff14

I see something weird, the word "Bar" appears upside down only if I disable HWA in FF14 (Nightly). With HWA on, "Bar" stays invisible.

In addition, turning off HWA implies a kind of "translation/contraction" of the word "Foo" (see the red lines on the screenshot).
(Reporter)

Comment 6

6 years ago
Created attachment 610728 [details]
about:support from Nightly

No problem, I attached it from the nightly. Let me know if you need anything else!

Comment 7

6 years ago
I can reproduce on Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20120329 Firefox/14.0a1 (in Parallels).
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout
Ever confirmed: true
Keywords: testcase
Product: Firefox → Core
QA Contact: untriaged → layout
Version: 11 Branch → Trunk
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 726766
You need to log in before you can comment on or make changes to this bug.