IM account cannot be created if less than 500MB available on disk (uncaught exception, NS_ERROR_FILE_TOO_BIG in mozIStorageConnection.setGrowthIncrement)

RESOLVED FIXED in Thunderbird 15.0

Status

Thunderbird
Instant Messaging
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Fallen, Assigned: florian)

Tracking

unspecified
Thunderbird 15.0
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I've experienced this on Windows:

1. Open the new chat account wizard in a new profile
2. It happens to me both with setting irc.mozilla.org and also the default settings
3. Go through the wizard until the finish button appears


Results:

* The finish button doesn't do anything.
* I get this error message randomly either once per wizard, or when clicking the finish button:

Timestamp: 3/29/2012 7:04:22 PM
Error: uncaught exception: [Exception... "Component returned failure code: 0x8052000f (NS_ERROR_FILE_TOO_BIG) [mozIStorageConnection.setGrowthIncrement]"  nsresult: "0x8052000f (NS_ERROR_FILE_TOO_BIG)"  location: "JS frame :: resource:///components/imContacts.js :: getDBConnection :: line 57"  data: no]

* Its not totally reliable when the message shows up. Sometimes it doesn't appear when clicking the finish button, but some time before.

* I'm not getting the error messages in bug 740288.
(Assignee)

Comment 1

6 years ago
Is your hard disk full? Do the file permissions allow Thunderbird to create more files in your thunderbird profile? (The error message you copied seems to indicate a failure to create the file blist.sqlite in your profile folder.)
(Assignee)

Comment 2

5 years ago
I understood the cause of this bug yesterday. The problem is caused by a change made in bug 666611 that make setGrowthIncrement throw if there's less than 500MB of free disk space. All C++ callers ignore the return value, and the only JS caller in mozilla-central (a unit test) has a try catch, so we should just add a try/catch too. We have just done that for Instantbird in https://bugzilla.instantbird.org/show_bug.cgi?id=1429
Summary: IRC account cannot be created (uncaught exception, NS_ERROR_FILE_TOO_BIG in mozIStorageConnection.setGrowthIncrement) → IM account cannot be created if less than 500MB available on disk (uncaught exception, NS_ERROR_FILE_TOO_BIG in mozIStorageConnection.setGrowthIncrement)
This will be included in bug 753807, which is merging the changes to chat/ from Instantbird back to comm-central.
Depends on: 753807
(Assignee)

Comment 4

5 years ago
The fix was pushed as https://hg.mozilla.org/comm-central/rev/81031e80b6cd as part of bug 753807.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 15.0
(Assignee)

Updated

5 years ago
Duplicate of this bug: 740288
Assignee: nobody → florian
You need to log in before you can comment on or make changes to this bug.