Last Comment Bug 740597 - 1-click in-app purchase
: 1-click in-app purchase
Status: RESOLVED WONTFIX
:
Product: Firefox for Android
Classification: Client Software
Component: Web Apps (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 14:11 PDT by Jennifer Arguello :ticachica
Modified: 2012-06-29 14:23 PDT (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jennifer Arguello :ticachica 2012-03-29 14:11:33 PDT

    
Comment 1 Jennifer Arguello :ticachica 2012-04-02 13:46:39 PDT
No fennec chrome needed for this.
Comment 2 Jennifer Arguello :ticachica 2012-04-04 16:38:43 PDT
Turns out there will need to be some chrome support. Adding the pertinent parties to the bug.
Comment 3 Harald Kirschner :digitarald 2012-04-04 17:09:34 PDT
Adding references for convenience:

Digital Goods for Express Checkout: https://cms.paypal.com/us/cgi-bin/?cmd=_render-content&content_ID=developer/e_howto_api_IntroducingExpressCheckoutDG
Mobile Payment Library (Android lib): https://www.x.com/developers/paypal/products/mobile-payment-libraries
Mobile Express Checkout (Web + Android lib): https://www.x.com/developers/paypal/products/mobile-express-checkout-library
Comment 4 Jason Smith [:jsmith] 2012-05-06 12:13:34 PDT
I question why this is needed for phase 2. Phase 2 intends to target chromeless support (which as we've seen already on desktop, is turning out to be a lot more work then we originally thought). I don't understand why this is needed for phase 2, as nailing down the chromeless support for phase 2 seems to be the critical path.
Comment 5 Kumar McMillan [:kumar] (needinfo all the things) 2012-05-06 15:12:57 PDT
Can someone summarize what this bug is about? The title is vague and there is no bug summary. I am mainly asking because isn't this feature already supported? I mean, the user would need to have pre-auth enabled and payments might take exactly 2 clicks but otherwise it will be fairly quick and painless.
Comment 6 Jason Smith [:jsmith] 2012-05-24 22:39:38 PDT
(In reply to Kumar McMillan [:kumar] from comment #5)
> Can someone summarize what this bug is about? The title is vague and there
> is no bug summary. I am mainly asking because isn't this feature already
> supported? I mean, the user would need to have pre-auth enabled and payments
> might take exactly 2 clicks but otherwise it will be fairly quick and
> painless.

That's what I thought too. Flagging productwanted. Jen - What is this feature? And why do we even need it? 2 clicks in the current marketplace in-app payment flow sounds okay to me. Why is there integration even on fennec native side?

Sounds like this bug should be resolved as a won't fix, given that the in-app payment flow already does a sufficient job at solving the in-app payments problem.
Comment 7 Jennifer Arguello :ticachica 2012-05-25 15:34:40 PDT
This bug was opened to be meta bug for the work of 1-click in-app payment support. At the time it was unclear if there was chrome support needed in fennec or if it could be done all in content. 

Now as I look at this I cannot find the requirement for 1-click in-app payment. Fligtar???

Looked in: 

https://wiki.mozilla.org/Kilimanjaro/ProductDraft
https://wiki.mozilla.org/AMO:Roadmap/2012
Comment 8 Justin Scott [:fligtar] 2012-05-30 00:29:13 PDT
The only native integration with in-app I can think of is the chrome-level dialog that we want in-app purchase screens to be displayed in for security. Based on a security discussion today, this is actually seen as a blocker for wider release of the Marketplace, but I'll let Rags comment on that as he took on this action item.
Comment 9 Jason Smith [:jsmith] 2012-06-19 13:25:16 PDT
This doesn't sound like this a blocker for the 1st release of Android WebRT, as were trying to get foundational pieces in place (it's not necessarily tied to the release of marketplace). I question the importance of this now in the short-term, given that we need to have paid apps on the marketplace that actually work first.

Note You need to log in before you can comment on or make changes to this bug.