bogus WebGL error in texSubImage2D on DOMElement/ImageData with type=FLOAT

RESOLVED DUPLICATE of bug 749711

Status

()

defect
RESOLVED DUPLICATE of bug 749711
7 years ago
7 years ago

People

(Reporter: bjacob, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: webgl-conformance)

No longer blocks: webgl-conformance
Whiteboard: webgl-conformance webgl-test-needed
Seems like this should be added to the conformance tests.
Er, a FLOAT+RGB canvas at 1024x1024 is 12MiB. 
You seem to be relying on context2d.createImageData(1024, 1024) to create your buffer, which only allocates 4MiB, since it assumes it's dealing with a 32bbp canvas of size 1024x1024.

Are you sure this should not be an error in Chrome?
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 749711
Removing webgl-test-needed as this is a dupe of another webgl-test-needed bug.
Whiteboard: webgl-conformance webgl-test-needed → webgl-conformance
You need to log in before you can comment on or make changes to this bug.